Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> recovering /etc/passwd, LF help correcting "root:x:0:0:root:/root:/bin/bash/nologin" i
fatfingers
post Jan 9 2008, 01:23 PM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 1
Joined: 9-January 08
Member No.: 13,242



Hello everyone. First post here.

Let me start by saying that I am dumb. No need to point that out. Let me tell you what I did that was dumb.

I edited /etc/passwd on my mail server to include the following entry:

root:x:0:0:root:/root:/bin/bash/nologin

And now I cannot su to root. I get the following error:

[redacted@mail bin]$ su -
Password:
su: /bin/bash/nologin: Not a directory

Which makes sense.

Can anyone help me find a way to edit that file to correct that entry?

I've tried a couple things, but

su root --shell=/bin/sh

and

su -p -c vim /etc/passwd

don't work. I get the same error.

Am I totally boned here?

TIA for any pointers.
Go to the top of the page
 
+Quote Post
michaelk
post Jan 11 2008, 09:41 AM
Post #2


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,800
Joined: 23-January 03
Member No.: 360



Boot using a rescue CD or live CD, mount your / partition and edit the file.
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 11th December 2017 - 11:17 PM