Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> Help with Make -v
mikalsaltveit
post Nov 24 2007, 05:27 PM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 2
Joined: 24-November 07
Member No.: 13,156



First, thank you to anyone who can help me. Now on to the fun:

************ Background ************
I am attempting to install the Multiverse server platform
http://update.multiverse.net/wiki/index.ph...ver_setup_guide
Onto a Sun Cobalt Cube 3 server
http://www.sun.com/hardware/serverapplianc...anual.qube3.pdf

I began by attempting to install JDK 5.0 Update 14.
During the make it alerted me that I had GLIBC-2.2.3, but needed 2.2.4.
So I found GLIBC-2.2.4
During ./configure it alerted me that my gmake was version 3.78 and I needed 3.80.
So I downloaded make-3.81
./configure, make and make install all run fine. No problems are listed.
However when I run "make -v" it tells me that 3.78 is the current version.

My question is:
Why is it not updating?

-Mikal
Go to the top of the page
 
+Quote Post
mikalsaltveit
post Nov 25 2007, 01:47 AM
Post #2


Whats this Lie-nix Thing?
*

Group: Members
Posts: 2
Joined: 24-November 07
Member No.: 13,156



UPDATE: I just ran make-3.80-5.src.rpm

'make -v' returns version 3.80 HOWEVER
'gmake -v' returns version 3.78

UPDATE: Exact error

./configure
loading cache ./config.cache
checking host system type... i586-pc-linux-gnu
checking sysdep dirs... sysdeps/i386/elf sysdeps/unix/sysv/linux/i386 sysdeps/unix/sysv/linux sysdeps/gnu sysdeps/unix/common sysdeps/unix/mman sysdeps/unix/inet sysdeps/unix/sysv/i386 sysdeps/unix/sysv sysdeps/unix/i386 sysdeps/unix sysdeps/posix sysdeps/i386/i586 sysdeps/i386/i486 sysdeps/i386/fpu sysdeps/i386 sysdeps/wordsize-32 sysdeps/ieee754/ldbl-96 sysdeps/ieee754/dbl-64 sysdeps/ieee754/flt-32 sysdeps/ieee754 sysdeps/generic/elf sysdeps/generic
checking for a BSD compatible install... /usr/bin/install -c
checking whether ln -s works... yes
checking for pwd... /bin/pwd
checking build system type... i586-pc-linux-gnu
checking for gcc... gcc
checking version of gcc... 2.95.2, ok
checking for gnumake... no
checking for gmake... gmake
checking version of gmake... 3.78.1, bad
configure: error:
*** These critical programs are missing or too old: make
*** Check the INSTALL file for required versions.
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 20th October 2017 - 01:06 PM