Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> SLES 10 Mail Server Config, Strange mail delivery problem
caznetworks
post Nov 6 2007, 01:42 AM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 17
Joined: 14-January 04
Member No.: 2,140



Hi all,

I've just installed SuSE Linux Enterprise Server 10 SP1 on a new mail server, and am stumped by a problem preventing messages from being delivered.

The relevant logfile entry (from /var/log/mail) is:
Nov 6 06:25:55 venus postfix/smtp[4923]: 9086C6332E4: to=<alex@venus.mydomain.com>, orig_to=<alex@mydomain.com>, relay=none, delay=22, status=bounced (Host or domain name not found. Name service error for name=localhost type=A: Host not found)

And sure enough, in the DNS log:
Nov 6 06:25:55 venus named[3769]: client 127.0.0.1#1032: query: localhost.mydomain.com IN A +

The 'localhost' zone is set up in BIND, and I've tried 'dig localhost', which correctly returns 127.0.0.1. What I don't understand is why the mail server's error is "name=localhost", which should work, yet the DNS server is apparently queried for "localhost.mydomain.com". I'm guessing this is the root of the problem.

TIA,

Alex
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 23rd October 2017 - 07:33 PM