Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )

Advanced DNS Management
New ZoneEdit. New Managment.


Sign Up Now
Reply to this topicStart new topic
> Standalone box and ISA proxy and yum update
post Jan 18 2007, 11:56 PM
Post #1

Whats this Lie-nix Thing?

Group: Members
Posts: 12
Joined: 19-January 05
Member No.: 4,538

With my box FC5 at work (Active Directory), I have been able to access the net , I have not logged in with my AD account , I logged in as username : root and password : forum,,,fake one (I know security implication, I have done this for test ).

First time when I tried to open a browser, window popped up asking me username and password for authentication to use internet (I entered my username: zillah and password:ad123 my active directory account,,,fake ), then I was able to browse the net.

When I tried to use the command below (via Terminal):

[root@local]#yum install yum (yumes),,,,It did not work, I believe because of the authentication (ISA proxy) that I mentioned above.

With the proxy , I followed the link below :

1- I added the line below to /etc/yum.conf
proxy=,,,,,,,,,,,,,,, because our ISA uses 8080 proxy
proxy_username=zillah,,,,,,,,,,,,,,,,,,,,,,,,,fake username
proxy_password=ad123,,,,,,,,,,,,,,,,,,,,,,,,,,fake password

Then I tried to use this :
[root]#yum update yum,,,,,,,,,,,,,,,,,,I received this error :

Loading "installation" Plugin
Settingup Update Process
Setting up repositories
Can not find a valid baseurl for repo:case
Error: Cannot find valid baseurl for repo:core

2- I removed the configuration above and I tried these:
http_proxy=" "
export http_proxy
yum update

[root@localhost # yum update yum
Traceback (most recent call last):
File "/usr/bin/yum", line 29, in ?
File "/usr/share/yum-cli/", line 80, in main
File "/usr/share/yum-cli/", line 177, in getOptionsConfig
self.doConfigSetup(fn=opts.conffil* e, root=root)
File "/usr/lib/python2.4/site-packages/* yum/", line 102, in doConfigSetup
self.conf = config.readMainConfig(fn, root)
File "/usr/lib/python2.4/site-packages/* yum/", line 567, in readMainConfig
File "/usr/lib/python2.4/site-packages/* yum/", line 126, in read,filename)
File "/usr/lib/python2.4/ConfigParser.p* y", line 267, in read
self._read(fp, filename)
File "/usr/lib/python2.4/ConfigParser.p* y", line 490, in _read
raise e
ConfigParser.ParsingError: File contains parsing errors: /etc/yum.conf
[line 15]: 'export http_proxy\n'
[line 16]: 'yum update\n'
Go to the top of the page
+Quote Post
post Apr 18 2007, 03:37 AM
Post #2

Its GNU/

Group: Support Specialist
Posts: 1,439
Joined: 3-January 04
From: Germany
Member No.: 2,069


I usualy never touch the yum.conf file for proxy settings, I do the following to allow yum and any other program to access internet via proxy server.

Edit the following file


using your favorite editor (mine is now)

nano /etc/profile

and add to the end of the file

export http_proxy=http://password:password@
export ftp_proxy=$http_proxy

if you used nano and your done editing press CTRL-O to write the file , then press ENTER to confirm.
then press CTRL-X to exit.
then you logout from the system and log back in.

And I think it should work without any problems.

Robert B

Robert Becskei
May the source be with us!
AMD X2-3800 @ 2400Mhz
2048MB DDR 400Mhz
DFI Lanparty UT4 NF4 ULTRA-D
GeForce 7800GT
Pioneer DVD-RW
17inch Samsung Syncmaster 757NF
WinXP Pro (SP2)/ CentOS 4.3
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:


RSS Lo-Fi Version Time is now: 21st March 2018 - 01:45 AM