Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> FC6 emacs startup extremely slow
wkhk
post Nov 19 2006, 04:03 PM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 3
Joined: 19-November 06
Member No.: 7,837



Hello,
after installing FC6 from scratch (standard installation, no upgrade) and installing emacs via "yum install emacs"
I noticed the emacs startup time is extremely long (~30s!!!). So it's completely unusable for me.
I found somewhere that putting

(modify-frame-parameters nil '((wait-for-wm . nil)))

in my .emacs file should fix such a problem, but it doesn't in my case. I used emacs on all previous FC versions
and never had any problems. It doesn't seem to be related to X, since "emacs -nw" is as slow. I tried Gnome, KDE, and command line. No change.

Any ideas? Do I need additional software?

Thanks,
wkhk
Go to the top of the page
 
+Quote Post
Hemant
post Dec 6 2006, 05:49 PM
Post #2


RMS is my Hero
******

Group: Support Specialist
Posts: 782
Joined: 6-October 02
From: Trichy,INDIA
Member No.: 29



That is wierd, Do you have swap enabled?

If no...please consider enabling swap.

Can I have a look at contents of your .emacs file?

Also, try emacs-snapshot package. It contains the latest builds.


--------------------
Hemant Kumar
user posted image
hemant@linuxhelp.net
Go to the top of the page
 
+Quote Post
wkhk
post Dec 6 2006, 10:02 PM
Post #3


Whats this Lie-nix Thing?
*

Group: Members
Posts: 3
Joined: 19-November 06
Member No.: 7,837



QUOTE (Hemant @ Dec 6 2006, 05:49 PM) *
That is wierd, Do you have swap enabled?

If no...please consider enabling swap.

Can I have a look at contents of your .emacs file?

Also, try emacs-snapshot package. It contains the latest builds.


Hi,
thanks for the response. I certainly could post the .emacs file, but the
problem is not related to that file, since the problem persists when I
remove my .emacs file completely.
Yes, swap is enabled and it's 2*RAM, i.e. 2 GB.
I noticed that the problem is related to networking. When I am connected
to a wireless network that has no WEP key enabled, it's fine. As soon
as I connect to a WEP key enabled network emacs (and emacs -nw) is
slow. I'm wondering whether it's related to the firewall or selinux????

Any hints, ideas are highly appreciated.

Thanks again,
w.
Go to the top of the page
 
+Quote Post
Hemant
post Dec 7 2006, 07:58 AM
Post #4


RMS is my Hero
******

Group: Support Specialist
Posts: 782
Joined: 6-October 02
From: Trichy,INDIA
Member No.: 29



turn off selinux, its hardly useful on notebooks.

since u are saying that problem is mostly when Wireless is enabled, I would assume other programs would also slow down.

anyway, consider posting message to the emacs mailing list,

http://lists.gnu.org/mailman/listinfo/help-gnu-emacs

but please try posting as much information as possible. Also, tell us about Emacs version you are using and what happens when you switch to Emacs snapshot.


--------------------
Hemant Kumar
user posted image
hemant@linuxhelp.net
Go to the top of the page
 
+Quote Post
wkhk
post Dec 9 2006, 09:23 AM
Post #5


Whats this Lie-nix Thing?
*

Group: Members
Posts: 3
Joined: 19-November 06
Member No.: 7,837



QUOTE (Hemant @ Dec 7 2006, 07:58 AM) *
turn off selinux, its hardly useful on notebooks.

since u are saying that problem is mostly when Wireless is enabled, I would assume other programs would also slow down.

anyway, consider posting message to the emacs mailing list,

http://lists.gnu.org/mailman/listinfo/help-gnu-emacs

but please try posting as much information as possible. Also, tell us about Emacs version you are using and what happens when you switch to Emacs snapshot.


Hi again,
ok, I turned off selinux. That did not solve the problem. I really believe it's the WEP key. I am not really
sure what to post. I used first emacs version that comes with FC6 (21-???). After contacting fedora-bugzilla
it was recommended to me to upgrade to emacs-22. So I have presently emacs-22.0.90-1.fc6 installed.
No change.

I run gnome and network-manager.

I'll contact the emacs mailing list.

Thanks.
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 11th December 2017 - 09:48 PM