Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> Partitions won't mount!, /home and windows drives won't mount-access denied
Lisally14
post Aug 19 2006, 05:31 PM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 5
Joined: 19-August 06
Member No.: 7,020



Linux won't mount my /home and windows partitions; I get an error saying access is denied.

The home partition is formatted as ext 3, the winows partition as vfat32.


I'm running Fedora Core 5 with KDE.


Any suggestions?
Go to the top of the page
 
+Quote Post
michaelk
post Aug 19 2006, 09:38 PM
Post #2


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,797
Joined: 23-January 03
Member No.: 360



/home if it is configured as a seperate partition should automatically mount at bootup. Please post your /etc/fstab file. To see what filesystems are already mounted use the mount command without options.

To mount your windows FAT32 partition
1. Create a directory to use as a mount point.i.e mkdir /media/windows_drive
2. Add an entry to the /etc/fstab file. i.e
/dev/hda1 /media/windows_drive vfat umask=000 0 0

You must be root to edit the /etc/fstab file. Change /dev/hda1 to match the partition of your windows drive.
Go to the top of the page
 
+Quote Post
Lisally14
post Aug 20 2006, 04:33 PM
Post #3


Whats this Lie-nix Thing?
*

Group: Members
Posts: 5
Joined: 19-August 06
Member No.: 7,020



QUOTE (michaelk @ Aug 19 2006, 10:38 PM) *
/home if it is configured as a seperate partition should automatically mount at bootup. Please post your /etc/fstab file. To see what filesystems are already mounted use the mount command without options.

To mount your windows FAT32 partition
1. Create a directory to use as a mount point.i.e mkdir /media/windows_drive
2. Add an entry to the /etc/fstab file. i.e
/dev/hda1 /media/windows_drive vfat umask=000 0 0

You must be root to edit the /etc/fstab file. Change /dev/hda1 to match the partition of your windows drive.


Thanks for the reply.

editing the fstab file doesn't work, even as root.


I can mount my windows drive manually using terminal commands, but I must remount it each tiime I log in. Is there a way to mount automatically without the terminal commands?

the system:/media directory lists the partition as present, but won't mount. Using the terminal command is the only i can get it to mount!
Go to the top of the page
 
+Quote Post
michaelk
post Aug 20 2006, 05:32 PM
Post #4


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,797
Joined: 23-January 03
Member No.: 360



You need to add an entry in the fstab file as previously posted to automatically mount the filesystem at bootup.

What are you using to edit the fstab file?
Go to the top of the page
 
+Quote Post
Lisally14
post Aug 20 2006, 06:00 PM
Post #5


Whats this Lie-nix Thing?
*

Group: Members
Posts: 5
Joined: 19-August 06
Member No.: 7,020



I'm using Kwrite-that's what it opens with, so it's probably the wrong program tongue.gif

What do you suggest using to edit it?
Go to the top of the page
 
+Quote Post
michaelk
post Aug 20 2006, 07:52 PM
Post #6


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,797
Joined: 23-January 03
Member No.: 360



If your root then it should work. I use the console for most configuration changes and use the vi editor.
Go to the top of the page
 
+Quote Post
Lisally14
post Aug 21 2006, 01:31 AM
Post #7


Whats this Lie-nix Thing?
*

Group: Members
Posts: 5
Joined: 19-August 06
Member No.: 7,020



Got it to work! biggrin.gif

Thanks so much for all your help!!!!
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 23rd October 2017 - 08:41 AM