Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> How do I discover what's blocking my audio?
Ben Pont
post Aug 15 2006, 12:32 AM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 3
Joined: 15-August 06
Member No.: 6,973



I seemed to have lost audio for some inexplicable reason. I wasn't doing anything out of the ordinary and the only active processes to speak of are two torrents I'm downloading with bittornado. I'd rather not close them at the moment since I'm getting good bandwidth.

Any troubleshooting suggestions?
Go to the top of the page
 
+Quote Post
Jim
post Aug 15 2006, 12:46 AM
Post #2


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,280
Joined: 19-November 03
From: University of Minnesota- TC
Member No.: 1,828



Logs logs logs logs logs.

If you haven't already, check your logs. Check these first (depending on your OS you will have one or the other)

/var/logs/messages
/var/log/system

do an ls on /var/logs see if there is anything else interesting, like maybe audio, but probably not. Always start with logs.


--------------------
--Jim Lester
jim@linuxhelp.net

Distro: Gentoo
System: AMD Athlon 3000+ XP 2.166 GHz
NVIDIA nForce2 IGP Chipset
1GB 333 MHz DDR SDRAM
NVIDIA nForce2 Dual Head 64 MB Graphics

Server Distro: CentOS
Go to the top of the page
 
+Quote Post
Ben Pont
post Aug 15 2006, 01:11 AM
Post #3


Whats this Lie-nix Thing?
*

Group: Members
Posts: 3
Joined: 15-August 06
Member No.: 6,973



QUOTE (Jim @ Aug 14 2006, 11:46 PM) *
Logs logs logs logs logs.

If you haven't already, check your logs. Check these first (depending on your OS you will have one or the other)

/var/logs/messages
/var/log/system

do an ls on /var/logs see if there is anything else interesting, like maybe audio, but probably not. Always start with logs.



Thanks for the quick response. I use Gentoo, which has ten billion different logs! In spite of that: /var/logs/messages and /var/log/system are non-existent. I'm checking on the Gentoo forum as well...no responses yet...

Here is the output when I tried to play an audio file using madplay in a terminal:
QUOTE
MPEG Audio Decoder 0.15.2 (beta) - Copyright 2000-2004 Robert Leslie et al.
ALSA lib pcm_dmix.c:862:(snd_pcm_dmix_open) unable to open slave
audio: esd_open_sound() failed

Go to the top of the page
 
+Quote Post
Jim
post Aug 15 2006, 11:47 AM
Post #4


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,280
Joined: 19-November 03
From: University of Minnesota- TC
Member No.: 1,828



Sorry, gentoo uses /var/log/syslog I forgot to list that one.

Gut instinct is that your alsa module isn't loaded

Run lsmod and make sure that the alsa module is loaded

Otherwise, run modprob -l to get a list of available modules, and then load the alsa module with modprobe whateverAslaIsCalled (note you wont need the full path like it displays, just the last part.

But start with syslog again and see what it tells you.


--------------------
--Jim Lester
jim@linuxhelp.net

Distro: Gentoo
System: AMD Athlon 3000+ XP 2.166 GHz
NVIDIA nForce2 IGP Chipset
1GB 333 MHz DDR SDRAM
NVIDIA nForce2 Dual Head 64 MB Graphics

Server Distro: CentOS
Go to the top of the page
 
+Quote Post
DS2K3
post Aug 15 2006, 05:01 PM
Post #5


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,284
Joined: 14-November 04
From: Southampton, Hampshire
Member No.: 4,165



If you're using metalog on Gentoo (like me), then it might be in /var/log/everything/current

D


--------------------
Fixed your problem? Let us know!
richard@linuxhelp.net

www.Gathr.co.uk Online Event Management
Go to the top of the page
 
+Quote Post
Ben Pont
post Aug 15 2006, 09:23 PM
Post #6


Whats this Lie-nix Thing?
*

Group: Members
Posts: 3
Joined: 15-August 06
Member No.: 6,973



QUOTE (Jim @ Aug 15 2006, 10:47 AM) *
Sorry, gentoo uses /var/log/syslog I forgot to list that one.

Gut instinct is that your alsa module isn't loaded

Run lsmod and make sure that the alsa module is loaded

Otherwise, run modprob -l to get a list of available modules, and then load the alsa module with modprobe whateverAslaIsCalled (note you wont need the full path like it displays, just the last part.

But start with syslog again and see what it tells you.


Actually, it was my bittorrent client (bittornado) that was somehow locking my audio device, so that no other app could access it! I don't even know why it would do this as it has no sound events so far as I can tell and there are no sound options in the preferences menu! How can I prevent this or any other app from locking down my sound device. It's nice to download a torrent in the background and still be able to have sound on my computer!!
Go to the top of the page
 
+Quote Post
Jim
post Aug 16 2006, 01:22 AM
Post #7


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,280
Joined: 19-November 03
From: University of Minnesota- TC
Member No.: 1,828



Humm.... thats a good question.

One of the things that linux has issues with is sharing the audio between two programs.

[Linux explinations skip if you could care less]

In linux, pretty much everything is represented by a file. Like your hard drive, its a file, say /dev/hda, and the partition might be /dev/hda1 by writting to, and reading from that file in a very special way you can write and read from the disk. So your sound car is /dev/sound (usually, not always). So again, if you read and write from that in a very special way, you can play (or record) sound. In order to have two things writting at the same time, you would have to have some way of blending the audio first, then writting to /dev/sound

[end]

To answer you question I am not sure there is any "simple" way to keep bit torrnado from locking up your sound. I would look through your settings and preferences for BT and make sure that there isn't anything you can disable (anything related to sound would be a good start). It might be that its grabbing the sound card to notify you when a file is finished and not releasing it correctly.

Ya so, I have no golden fix for you on this one.

Wait, though, is bittornado a command line program or a gui? If its a command line program, you could run it from one of the other terminals and it probably wouldn't grab sound. Just a thought, I assume bittornado is a gui though, so that doesn't help you.


--------------------
--Jim Lester
jim@linuxhelp.net

Distro: Gentoo
System: AMD Athlon 3000+ XP 2.166 GHz
NVIDIA nForce2 IGP Chipset
1GB 333 MHz DDR SDRAM
NVIDIA nForce2 Dual Head 64 MB Graphics

Server Distro: CentOS
Go to the top of the page
 
+Quote Post
DS2K3
post Aug 17 2006, 03:57 AM
Post #8


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,284
Joined: 14-November 04
From: Southampton, Hampshire
Member No.: 4,165



Try starting your music player or whatever before you start BitTornado. Of, if poss, sere if you can instruct BitTornado to use an alternative sound system like Arts. If arts is running and you instruct all your programs to use it (KDE programs should use it by defauly anyway)then it usually does a pretty good job of mixing the various sounds for you.


--------------------
Fixed your problem? Let us know!
richard@linuxhelp.net

www.Gathr.co.uk Online Event Management
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 11th December 2017 - 09:53 PM