Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> dhcpcd not answering
Arla
post Aug 8 2006, 01:31 PM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 4
Joined: 8-August 06
From: Stockholm, Sweden
Member No.: 6,922



Hello Linux World.

I have, as quite new to Linux, just installed Gentoo. The installation was done from a livecd, and choosing only files from the disc, I don't know if it used Internet at all.

The problem is that now (as I boot the installed Gentoo system) the network connection isn't working. I'm using a wireless network card 3Com 3CRDW696. I figured "Gentoo Network Configuration/Getting Started" from the Gentoo Linux Handbook would help. But at the part where I "/etc/init.d/net.eth0 start", the "dhcpcd" doesn't answer at all:
CODE
* Starting eth0
*   Bringing up eth0
*     dhcp
*       Running dhcpcd ...
and then just nothing happens until I cancel it with Ctrl+C. I suppose from the name of the command that it's looking for a DHCP server? In that (or any other) case, what is there to do about it?
Go to the top of the page
 
+Quote Post
DS2K3
post Aug 8 2006, 01:41 PM
Post #2


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,284
Joined: 14-November 04
From: Southampton, Hampshire
Member No.: 4,165



Well, the easiest thing to do would be to configure a static ip address for the interface. I'm not sure how it works anymore, I used to know, but then Gentoo changed the format and location of the files and I haven't actually managed to make it work since unsure.gif

It should be in the guide though smile.gif


--------------------
Fixed your problem? Let us know!
richard@linuxhelp.net

www.Gathr.co.uk Online Event Management
Go to the top of the page
 
+Quote Post
Jim
post Aug 8 2006, 02:49 PM
Post #3


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,280
Joined: 19-November 03
From: University of Minnesota- TC
Member No.: 1,828



Is this a laptop? Typically speaking, eth0 is going to be your hard-wire network connection. eth1 will be your wireless.

So it looks to me like your computer is hanging on not getting a DHCP lease on the ethernet, not the wireless.

Last time I tried, which was a while ago, Gentoo didn't have default wireless support, so you may have to install drivers to get the wireless card working correctly. At the very least, its a little more complicated to start than a wired NIC since you have to choose a network to join.

When you run ifconfig -a what do you see. You should see at least three things. eth0, eth1 and lo. eth0 will be your hard-wire NIC, eth1 should be your wireless and lo is your loopback, don't worry about that.

After that, you will need to configure your wireless card, so lets just start with making sure it shows up.


--------------------
--Jim Lester
jim@linuxhelp.net

Distro: Gentoo
System: AMD Athlon 3000+ XP 2.166 GHz
NVIDIA nForce2 IGP Chipset
1GB 333 MHz DDR SDRAM
NVIDIA nForce2 Dual Head 64 MB Graphics

Server Distro: CentOS
Go to the top of the page
 
+Quote Post
Arla
post Aug 8 2006, 04:59 PM
Post #4


Whats this Lie-nix Thing?
*

Group: Members
Posts: 4
Joined: 8-August 06
From: Stockholm, Sweden
Member No.: 6,922



QUOTE (Jim @ Aug 8 2006, 09:49 PM) *
Is this a laptop? Typically speaking, eth0 is going to be your hard-wire network connection. eth1 will be your wireless.

Last time I tried, which was a while ago, Gentoo didn't have default wireless support, so you may have to install drivers to get the wireless card working correctly.

When you run ifconfig -a what do you see. You should see at least three things. eth0, eth1 and lo.
No, it's not a laptop. Will my wireless card still be eth1?

I used the Gentoo livecd for internet, so it must have default wireless support.

ifconfig -a shows eth0, lo, wifi0 and wlan0 ohmy.gif
Go to the top of the page
 
+Quote Post
Jim
post Aug 8 2006, 06:39 PM
Post #5


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,280
Joined: 19-November 03
From: University of Minnesota- TC
Member No.: 1,828



So ya, wifi0, they changed the naming system. Thats the problem. So ya, it will choke if you don't have a cable plugged in.

You need to disable eth0 at boot.

so run rc-update del eth0 default and it wont hang on boot like that.

Then, once your booted up, you will need to configure wifi0 to connect to the internet. I have never configured wireless in gentoo, so I can't really help you. I recomend trying gentoo.org or maybe somebody else here can help you out.

If its always connecting to the same box, you can add wifi0 to the boot level after its configured.

rc-update add wifi0 default

But I don't think that will work without configuring it. The key thing is eth0 is not your wirless card, wifi0 is.


--------------------
--Jim Lester
jim@linuxhelp.net

Distro: Gentoo
System: AMD Athlon 3000+ XP 2.166 GHz
NVIDIA nForce2 IGP Chipset
1GB 333 MHz DDR SDRAM
NVIDIA nForce2 Dual Head 64 MB Graphics

Server Distro: CentOS
Go to the top of the page
 
+Quote Post
Arla
post Aug 8 2006, 07:54 PM
Post #6


Whats this Lie-nix Thing?
*

Group: Members
Posts: 4
Joined: 8-August 06
From: Stockholm, Sweden
Member No.: 6,922



I just noticed that there is a specific "Wireless" section in the Gentoo Handbook sleep.gif Tomorrow I'll get the computer out to the living room, where the router is, plug it in directly and try to make it work from there.
Go to the top of the page
 
+Quote Post
Arla
post Aug 10 2006, 02:33 AM
Post #7


Whats this Lie-nix Thing?
*

Group: Members
Posts: 4
Joined: 8-August 06
From: Stockholm, Sweden
Member No.: 6,922



Okay, fixed it. I don't really know what it was, I just did excactly what was said in the Gentoo Networling/Getting Started section of the Handbook. One thing to regard is that I had to use a static ip address. After some reboots it just worked. Thank you two anyways, and "hello from Lunix" smile.gif
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 24th October 2017 - 06:27 AM