Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> Tux Racer Problems, Freeze, crach and burn
invisibout
post Apr 20 2003, 08:19 AM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 8
Joined: 20-April 03
Member No.: 700



When I start a new game in Tux Racer it flickers then quits and freezes. Before it was working fine but randomly it stopped working. I searched on the nvidia forum for a similar problem and all i got was add a certain line to xf86config, which I did, rebooted and it still didnt work (something about nvagp). Im using Redhat 8 with a GF4 4200 128 with the latest drivers....whichever those are....can someone tell me what I can do to fix that? (fyi Unreal Tournament 2003 works fine) Thanx
Go to the top of the page
 
+Quote Post
Corey
post Apr 21 2003, 07:10 AM
Post #2


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 1,254
Joined: 21-September 02
From: St John's, Newfoundland, Canada
Member No.: 3



I'm guesing you're using the latest drivers from the NVidia website correct? As well, did you download and install the NVIDIA_Glx package and installed that as well? Were these packages installed from source or from per-compiled packages? If all else fails, you can install them from source.

In your XF86Config file, make sure you have "GLcore" and "DRI" commented (or deleted) out of your loaded modules list and be sure to have "glx" in there.

In X-Windows, open up a terminal-emulator and run glxinfo, at the very top of the output (you may have to scoll up) make sure you see "Direct Rendering = Yes". Run "glxgears" and make sure that is able to run fine and smooth (with a GEforce 4 , you should see really high FPS.

After then, from the terminal-emulator, run Tuxracer, play until it quits on you or whatever, then go back to the console and see what, if any, errors are spit back? Could it be a SDL-specific error (SDL Parachute Deployed) or anything else? If possible, please reply back with whatever errors appear.

Thank you.


--------------------
Corey Quilliam
(former) Linuxhelp.ca Administrator
cquilliam-AT-gmail-dot-com

Want to help out Linuxhelp.net? Check out our Linuxhelp Wiki and see if there are some articles you would like to submit!!

--
Ubuntu 8.04 64-bit - Work Laptop (HP-Compaq NC6400 Core2)
Kubuntu 8.04 64-bit - Desktop (HP m8120n QuadCore)
Ubuntu 6.04 - Server (I'm not upgrading this baby until support runs out in 2012) (Some old POS dell)
Go to the top of the page
 
+Quote Post
invisibout
post Apr 21 2003, 08:17 PM
Post #3


Whats this Lie-nix Thing?
*

Group: Members
Posts: 8
Joined: 20-April 03
Member No.: 700



I used the latest drivers from the nvidia site, glcore was deleted and i commented a section on dri, (at this point i havent installed the glx drivers) then i ran glxinfo and it said yes, i ran the gears and the fps were in the thousands, i ran tuxracer and when it got the error it said "Aborted". I then installed NVIDIA_kernel-1.0-3123.rh73up.i686.rpm and then NVIDIA_GLX-1.0-3123.i386.rpm. I tried to run tuxracer in the terminal and it came up with "tuxracer: relocation error: /usr/lib/libGLcore.so.1: undefined symbol: glPrimitiveRestartNV" , i rebooted and the x window system had a error and had to revert to crappy settings sad.gif . Please tell me what i did wrong, Thanx
Go to the top of the page
 
+Quote Post
Corey
post Apr 22 2003, 11:16 AM
Post #4


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 1,254
Joined: 21-September 02
From: St John's, Newfoundland, Canada
Member No.: 3



I don't think you really did anything "wrong". The only problem I have with what you did was installing the RPM's. I don't like using pre-packaged binaries for the NVidia drivers, I'd rather install them from source, a lot quicker, easier, and compatiple with what you're running. The only down-fall is that you have to have the kernel headers installed in order to compile the NVidia kernel driver.

Try removing the GLX and Kernel packages for NVidia, and re-installing them as source. I just create a directory in /usr/src called "nvidia, and extract the two packages there. Install the kernel module first, then the glx package.

Note that in the latest release, NVidia has a automatic downloader for the drivers, so you can use that if you want. But i still rather the source packages.


--------------------
Corey Quilliam
(former) Linuxhelp.ca Administrator
cquilliam-AT-gmail-dot-com

Want to help out Linuxhelp.net? Check out our Linuxhelp Wiki and see if there are some articles you would like to submit!!

--
Ubuntu 8.04 64-bit - Work Laptop (HP-Compaq NC6400 Core2)
Kubuntu 8.04 64-bit - Desktop (HP m8120n QuadCore)
Ubuntu 6.04 - Server (I'm not upgrading this baby until support runs out in 2012) (Some old POS dell)
Go to the top of the page
 
+Quote Post
invisibout
post Apr 22 2003, 03:57 PM
Post #5


Whats this Lie-nix Thing?
*

Group: Members
Posts: 8
Joined: 20-April 03
Member No.: 700



How do I delete a package? I went into the package manager under System settings and all I saw were the packages that are available from the install cds...how do I remove the other packages?
Go to the top of the page
 
+Quote Post
Corey
post Apr 23 2003, 06:26 AM
Post #6


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 1,254
Joined: 21-September 02
From: St John's, Newfoundland, Canada
Member No.: 3



Open up your console , change into root with the "su" command, then run:

QUOTE
rpm -qa | grep NVIDIA


then remove each occurance of packages starting with NVIDIA

QUOTE
rpm -e NVIDIA_kernel-1.0-3123
rpm -e NVIDIA_GLX-1.0-3123


That should do it.


--------------------
Corey Quilliam
(former) Linuxhelp.ca Administrator
cquilliam-AT-gmail-dot-com

Want to help out Linuxhelp.net? Check out our Linuxhelp Wiki and see if there are some articles you would like to submit!!

--
Ubuntu 8.04 64-bit - Work Laptop (HP-Compaq NC6400 Core2)
Kubuntu 8.04 64-bit - Desktop (HP m8120n QuadCore)
Ubuntu 6.04 - Server (I'm not upgrading this baby until support runs out in 2012) (Some old POS dell)
Go to the top of the page
 
+Quote Post
invisibout
post Apr 23 2003, 05:11 PM
Post #7


Whats this Lie-nix Thing?
*

Group: Members
Posts: 8
Joined: 20-April 03
Member No.: 700



when I type make it spits out this
QUOTE
You appear to be compiling the NVdriver kernel module with
a compiler different from the one that was used to compile
the running kernel. This may be perfectly fine, but there
are cases where this can lead to unexpected behaviour and
system crashes.

If you know what you are doing and want to override this
check, you can do so by setting IGNORE_CC_MISMATCH.

In any other case, set the CC environment variable to the
name of the compiler that was used to compile the kernel.

*** Failed cc sanity check. Bailing out! ***
make: *** [gcc-check] Error 1
Go to the top of the page
 
+Quote Post
Corey
post Apr 24 2003, 05:28 PM
Post #8


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 1,254
Joined: 21-September 02
From: St John's, Newfoundland, Canada
Member No.: 3



As it states, the kernel you are running was compiled with a different version of gcc then what you're trying to use to compile the drivers.

I just ran into this problem too when i changed my symlink in /usr/bin/gcc over to gcc-3.2 . To get around this problem, you can either recompile your kernel with the current version of gcc that you have on your system, or you can set the environment variable and compile it like it is:

QUOTE
export IGNORE_CC_MISMATCH=1
make install


That should allow it to compile fine, i haven't had any trouble ignoring it.


--------------------
Corey Quilliam
(former) Linuxhelp.ca Administrator
cquilliam-AT-gmail-dot-com

Want to help out Linuxhelp.net? Check out our Linuxhelp Wiki and see if there are some articles you would like to submit!!

--
Ubuntu 8.04 64-bit - Work Laptop (HP-Compaq NC6400 Core2)
Kubuntu 8.04 64-bit - Desktop (HP m8120n QuadCore)
Ubuntu 6.04 - Server (I'm not upgrading this baby until support runs out in 2012) (Some old POS dell)
Go to the top of the page
 
+Quote Post
invisibout
post Apr 25 2003, 02:43 PM
Post #9


Whats this Lie-nix Thing?
*

Group: Members
Posts: 8
Joined: 20-April 03
Member No.: 700



Thanx, but when I type make install it returns the following...
QUOTE
cc -c -Wall -Wimplicit -Wreturn-type -Wswitch -Wformat -Wchar-subscripts -Wparentheses -Wpointer-arith -Wcast-qual -Wno-multichar  -O -MD -D__KERNEL__ -DMODULE
-D_LOOSE_KERNEL_NAMES -DNTRM -D_GNU_SOURCE -DRM_HEAPMGR -D_LOOSE_KERNEL_NAMES -D__KERNEL__ -DMODULE  -DNV_MAJOR_VERSION=1 -DNV_MINOR_VERSION=0 -DNV_PATCHLEVEL=3123  -DNV_UNIX  -DNV_LINUX  -DNVCPU_X86      -I. -I/usr/src/linux/include -Wno-cast-qual nv.c
make: cc: Command not found
make: *** [nv.o] Error 127

man im cursed or sumthing tongue.gif
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 23rd October 2017 - 11:15 PM