Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> YUM is screwed
fullur
post Jul 14 2006, 12:23 PM
Post #1


./configure
***

Group: Members
Posts: 50
Joined: 24-September 05
Member No.: 5,549



I can't open YUM from the GUI. When I try to run it from a terminal window I get the following:

There was a problem importing one of the Python modules
required to run yum. The error leading to this problem was:

No module named cElementTree

Please install a package which provides this module, or
verify that the module is installed correctly.

It's possible that the above module doesn't match the
current version of Python, which is:
2.4.3 (#1, Jun 13 2006, 11:46:08)
[GCC 4.1.1 20060525 (Red Hat 4.1.1-1)]

If you cannot solve this problem yourself, please go to
the yum faq at:
http://wiki.linux.duke.edu/YumFaq

I went to the wiki and tried what they suggested, which was to download the source rpm and run rpmbuild --rebuild yum*.src.rpm. When I try that command I get a message saying "rpmbuild: command not found".

Can anyone help me? I would appreciate it.


--------------------
Fedora Core 5
AMD Athlon XP 2400+
768 MB PC266 RAM
Go to the top of the page
 
+Quote Post
fullur
post Jul 17 2006, 01:00 PM
Post #2


./configure
***

Group: Members
Posts: 50
Joined: 24-September 05
Member No.: 5,549



I seem to have royally screwed my system. I can't do anything with rpm files, and when I run ./configure I get this:

CODE
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking whether to enable maintainer-specific portions of Makefiles... no
checking for style of include used by make... GNU
checking for gcc... no
checking for cc... no
checking for cc... no
checking for cl... no
configure: error: no acceptable C compiler found in $PATH
See `config.log' for more details.


Everything had been working until a couple of days ago. I think it messed up after I updated my main files for Fedora using YUM Updater.


--------------------
Fedora Core 5
AMD Athlon XP 2400+
768 MB PC266 RAM
Go to the top of the page
 
+Quote Post
fullur
post Jul 17 2006, 06:09 PM
Post #3


./configure
***

Group: Members
Posts: 50
Joined: 24-September 05
Member No.: 5,549



While I was fairly certain that I had run "make" on this system a couple of times previously, I must have been wrong as I appear to not have a compiler installed. That said, without YUM working and without a compiler, is there any way that I am going to be able to get arround re-installing from scratch?


--------------------
Fedora Core 5
AMD Athlon XP 2400+
768 MB PC266 RAM
Go to the top of the page
 
+Quote Post
Linux_Weary
post Jul 18 2006, 02:12 AM
Post #4


Whats this Lie-nix Thing?
*

Group: Members
Posts: 2
Joined: 18-July 06
Member No.: 6,790



have you thought of downloading the python module? Even easier would be to just download the latest version of python and install it.


--------------------
My distro is: FC5_x86_64
Go to the top of the page
 
+Quote Post
fullur
post Jul 18 2006, 09:08 AM
Post #5


./configure
***

Group: Members
Posts: 50
Joined: 24-September 05
Member No.: 5,549



QUOTE (Linux_Weary @ Jul 18 2006, 02:12 AM) *
have you thought of downloading the python module? Even easier would be to just download the latest version of python and install it.


Actually I have. Unfortunately since I have no compiler installed and (although I couldn't locate an rpm version of python anyway) rpms don't respond (I assume this is because of YUM being non-operational) that's not an option I have been able to run with. If FC5 comes with another way of handling rpms and you can point me to it and an rpm version of python I suppose that would work, but right now I am stuck. sad.gif


--------------------
Fedora Core 5
AMD Athlon XP 2400+
768 MB PC266 RAM
Go to the top of the page
 
+Quote Post
DS2K3
post Jul 18 2006, 10:20 AM
Post #6


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,284
Joined: 14-November 04
From: Southampton, Hampshire
Member No.: 4,165



you can use the rpm command directly to uninstall, then reinstall yum. First, run "rpm -e yum" to get yum uninstalled. Then locate the yum RPMS (download them, or find them on the CDs) and run "rpm -i name_of_rpm(s)" (you can use wildcards. So, you could just copy all yum rpms to a folder and run "rpm -i *.rpm")

D


--------------------
Fixed your problem? Let us know!
richard@linuxhelp.net

www.Gathr.co.uk Online Event Management
Go to the top of the page
 
+Quote Post
fullur
post Jul 18 2006, 07:12 PM
Post #7


./configure
***

Group: Members
Posts: 50
Joined: 24-September 05
Member No.: 5,549



QUOTE (DS2K3 @ Jul 18 2006, 10:20 AM) *
you can use the rpm command directly to uninstall, then reinstall yum. First, run "rpm -e yum" to get yum uninstalled. Then locate the yum RPMS (download them, or find them on the CDs) and run "rpm -i name_of_rpm(s)" (you can use wildcards. So, you could just copy all yum rpms to a folder and run "rpm -i *.rpm")

D

Thank you, at least I don't have a non-functional YUM installation anymore. Unfortunately, this didn't fix the problem with the missing module. Apparently it is a Python module that is missing. After I re-installed YUM I trie to run it and got an error message identical to the one above. So now I need to hunt down an rpm for that.


--------------------
Fedora Core 5
AMD Athlon XP 2400+
768 MB PC266 RAM
Go to the top of the page
 
+Quote Post
fullur
post Jul 18 2006, 07:23 PM
Post #8


./configure
***

Group: Members
Posts: 50
Joined: 24-September 05
Member No.: 5,549



I found in the FC5 Core Packages list "python-elementtree-1.2.6-4.2.1.i386.rpm". I went to install that and it said that the version I already had was newer (python-elementtree-1.2.6-6.2.el4.rf). I uninstalled that one, installed the rpm I had downloaded, then re-installed YUM. It's working again. Thank you for all of the help.


--------------------
Fedora Core 5
AMD Athlon XP 2400+
768 MB PC266 RAM
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 19th October 2017 - 08:37 PM