Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )

Advanced DNS Management
New ZoneEdit. New Managment.


Sign Up Now
Reply to this topicStart new topic
> CoLinux Help Possible problem with XML file
post Jul 11 2006, 06:56 PM
Post #1

Whats this Lie-nix Thing?

Group: Members
Posts: 1
Joined: 11-July 06
Member No.: 6,740

Hi I am trying to install Colinux, I am going through the install and everything goes right, up until I go to start Colinux W/ Debian from the Batchfile I made and it comes up with this screen:

# This process will install (if necessary) the coLinux modules for the
# coLinux kernel.
Determining /, found.
Mounting /
mount: Mounting /dev/dobd0 on /mnt/linux failed: No Such Device
closing /
Unmount: forced umount of <null> failed!
failed. <trying again>
umount: forced umount of <null> Failed!

Initrd: Unmount Failed on rootfs
Try to run coLinux without initrd. Comment out initrd from configuation.
Press <Enter> to continue.

(If you hit enter and it exits the command prompt (I put this in the target area of the batchfile that I created: colinux-daemon.exe -t nt -c default.colinux.xml )) I have tried to delete out the initrd text in configuration(thinking that Comment out initrd means to delete it) but it doesnt work with it. I was hoping you could help get this started successfully. I wasn't quite sure if there was a problem with the xml file I have so I posted it below in hopes someone could help.

Here is the Configuration file I have for it (default.colinux.xml):

<?xml version="1.0" encoding="UTF-8" ?>
- <colinux>
- <!-- This line needs to point to your root file system.
For example change "root_fs" to the name of the Debian image.
Inside coLinux it will be /dev/cobd0

Block Device Aliasing: You can now handle most dual-boot issues
by adding an alias="devname" to block_device. i.e. alias="hda",
alias="hda1" You can do this for SCSI as well as IDE. You need
to be aware that if you add an alias, you need to change your
bootparams root="devname" appropriately (you may need to use
devfs naming in some situations).
<block_device index="0" path="\DosDevices\c:\coLinux\root_fs" enabled="true" />
- <!-- This line can specify a swap file if you wish, or an additional
image file, it will /dev/cobd1. Additional block_devices can
be specified in the same manner by increasing the index
<block_device index="1" path="\DosDevices\c:\coLinux\swap_device" enabled="true" />
- <!-- This is an experimental feature, it may not function completely.
<cofs_device index="0" type="flat" path="\DosDevices\C:\colinux\swap_384MB" enabled="true" />

- <!-- bootparams allows you to pass kernel boot parameters
- <!-- Initial RamDISK (initrd) support
<initrd path="initrd.gz" />
- <!-- image allows you to specify the kernel to boot
<image path="vmlinux" />
- <!-- this line allows you to specify the amount of memory available
to coLinux
<memory size="384" />
- <!-- This allows you to modify networking parameters, see the README
or website or wiki for more information
<network index="0" type="tap" />

Much Help Appreciated! Thanks,

Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:


RSS Lo-Fi Version Time is now: 19th June 2018 - 07:54 AM