Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> df weirdness
Erik
post Jul 6 2006, 11:04 AM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 4
Joined: 6-July 06
Member No.: 6,705



Hi all,
I have a server here that complains of a full disk.
df says:
CODE
Filesystem           1k-blocks      Used Available Use% Mounted on
/dev/sda2               995872    971084         0 100% /

which tells me that I have a 995 MB disk, which contains 971 MB of data, so about 20 MB should be available. Yet it registers full. Huh?
So I restarted the machine, under the assumption that some file had been locked and become invisible... no dice; same result.
tried lsof |grep deleted to find open files, nothing.

Now the fact that this disk registers full is a serious problem.
Any pointers?

-Erik
Go to the top of the page
 
+Quote Post
markjr
post Jul 6 2006, 12:28 PM
Post #2


./configure
***

Group: Admin
Posts: 62
Joined: 9-February 06
Member No.: 6,054



QUOTE (Erik @ Jul 6 2006, 12:04 PM) *
Hi all,
I have a server here that complains of a full disk.
df says:
CODE
Filesystem           1k-blocks      Used Available Use% Mounted on
/dev/sda2               995872    971084         0 100% /

which tells me that I have a 995 MB disk, which contains 971 MB of data, so about 20 MB should be available. Yet it registers full. Huh?
So I restarted the machine, under the assumption that some file had been locked and become invisible... no dice; same result.
tried lsof |grep deleted to find open files, nothing.

Now the fact that this disk registers full is a serious problem.
Any pointers?

-Erik


Not sure it'll help, but what does df -i report? -i shows you your inode count. I've had a situation where df was showing space available but applications were throwing off "disk full" errors.

Not the exact same thing you have but have a look at your inode usage.
Go to the top of the page
 
+Quote Post
michaelk
post Jul 6 2006, 01:12 PM
Post #3


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,800
Joined: 23-January 03
Member No.: 360



What type of filesystem is sda2? If it is ext2 or ext3 then the missing space is probably reserved space. The default when formated is 5% but can be changed. Look at the output of the command

tune2fs -l
Go to the top of the page
 
+Quote Post
Erik
post Jul 6 2006, 02:22 PM
Post #4


Whats this Lie-nix Thing?
*

Group: Members
Posts: 4
Joined: 6-July 06
Member No.: 6,705



Thank you for your quick replies, I'm really stumped here.
First of all, df -i

# df -i
Filesystem Inodes IUsed IFree IUse% Mounted on
/dev/sda2 257280 14868 242412 6% /

So I have at least 6% inodes free...

then, tunefs. sda2 is indeed ext2, and your remark does seem to make sense (even if this never showed up before today; and we've been running in this setup for a few years now)
interesting...
tune2fs -l /dev/sda2
tune2fs 1.17, 26-Oct-1999 for EXT2 FS 0.5b, 95/08/09
Filesystem volume name: <none>
Last mounted on: /mnt

but we're mounted on / (?)

Filesystem state: not clean
but fsck does not report any errors (?)

Inode count: 257280
Block count: 257040
Reserved block count: 12852
Free blocks: 6211
Free inodes: 242412

so we should be seeing at least some free space...

So now what do I do about this?
Also, when I delete files, the free-block count goes up, but the 100% does not go down !?
And I can apparently copy files onto the partition without problems; but the clients use samba and the keep getting "disk full" messages. this is weird!

Any ideas on how to repair this?

-Erik
Go to the top of the page
 
+Quote Post
michaelk
post Jul 6 2006, 05:09 PM
Post #5


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,800
Joined: 23-January 03
Member No.: 360



From the ouput of tune2fs it appears that your reserved space is 5%. Your not going to see less then 100% use until you delete enough files to go below 5% mark or ~946MB used. This is due to reserved space.

Reserved space is to allow root to login in case the filesystem becomes full and to keep fragementation down. You can change the amount via the tune2fs utility. With / filesystem I do not recommend setting to zero.

What distro/version of linux are you running? How is your system partitioned?
You need to delete some more files. Make sure the log files located @ /var/log are not getting out of hand.
A long term solution would be to move the share(s) and /home if that is were your clients are saving data to a seperate drive or partition.
Go to the top of the page
 
+Quote Post
Erik
post Jul 7 2006, 02:47 AM
Post #6


Whats this Lie-nix Thing?
*

Group: Members
Posts: 4
Joined: 6-July 06
Member No.: 6,705



biggrin.gif Wheehee! It worked!
It took me a while, but finally I deleted enough files to get below the reserved blocks mark, and lo and behold! the 100% started to drop.

My users are really happy now, and so am I.

Thanks a lot, guys! biggrin.gif

-Erik
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 18th December 2017 - 02:01 AM