Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Closed TopicStart new topic
> getting FC5 to do NOTHING when I insert a CD
holy Teach
post May 31 2006, 11:24 PM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 3
Joined: 31-May 06
From: Austin, TX
Member No.: 6,463



Okay, I'm a longtime Linux user. This didn't used to be a problem, but as distros have gotten more user friendly they now do automatic things that I don't want them to. Usually I can figure out how to get back to the old behavior, but this is one that has me stymied.

I'm running Fedora Core 5 and use KDE. I have a SCSI controller and a SCSI CD-ROM drive, which lives at /dev/scd0.

In years past (with previous distros), when I put a CD into the drive, it would do nothing. It wouldn't scan the disk, wouldn't mount it, NOTHING. This is what I want, because 99.9% of the time I insert a CD-ROM it's so I can use command-line cdparanoia to rip the audio tracks off of it.

Under FC5's version of KDE (3.5.2-0.2.fc5, if you care), when I insert a CD, it spins up and makes a lot of noise, but does *not* mount the drive, though an icon appears on the desktop that will allow me to do so.

However, when I try to use cdparanoia, I get the following error message:

QUOTE
Error trying to open /dev/scd0 exclusively (Device or resource busy).


After much trial and error, I was able to determine that if I type

QUOTE
killall kio_audiocd


...and then wait two or three seconds, then cdparanoia has no problems and I can rip normally.

My question is:

1) What is the right way to fix this? I'm worried that killing kio_audiocd isn't the best thing to do.
2) How do I get this change to stick. I want to be able to insert CDs and have KDE leave them the heck alone . I can manually mount a drive if I want it mounted.
3) If possible, I'd still like KDE to automount flash drives and other removable media.

It seems like this ought to be easy, but I've searched in the control center, process list and man pages and haven't been able to quite figure out the culprit.

Thanks in advance.


--------------------
Graham Mitchell, computer science teacher -- Leander High School
Go to the top of the page
 
+Quote Post
Robert83
post Jun 1 2006, 08:43 AM
Post #2


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,439
Joined: 3-January 04
From: Germany
Member No.: 2,069



Hello,

try looking in the following files for the solution

/etc/sysconfig/autofs

/etc/auto.master
/etc/auto.misc

the package that does the automount is
rpm -q autofs

rpm -ql autofs , to list all installed files, so that you can find any config file, and all the documents it has.


Hope this helps move in to the right direction, and solve your issue.

Sincerely
Robert B


--------------------
Robert Becskei
robert83@linuxhelp.net
--------------------
May the source be with us!
--------------------
AMD X2-3800 @ 2400Mhz
2048MB DDR 400Mhz
DFI Lanparty UT4 NF4 ULTRA-D
GeForce 7800GT
250GB+250GB
Pioneer DVD-RW
17inch Samsung Syncmaster 757NF
WinXP Pro (SP2)/ CentOS 4.3
--------------------
Go to the top of the page
 
+Quote Post
holy Teach
post Jun 21 2006, 05:04 PM
Post #3


Whats this Lie-nix Thing?
*

Group: Members
Posts: 3
Joined: 31-May 06
From: Austin, TX
Member No.: 6,463



QUOTE (Robert83 @ Jun 1 2006, 08:43 AM) *
the package that does the automount is
rpm -q autofs


I tried your suggestion, but it didn't change anything. Even when I turn off the autofs service, I still experience the EXACT same behavior.

I did:

CODE
# service autofs stop


...then checked the process list to make sure. I then inserted an audio CD, and *something* still touches the drive, launching a couple kio_audio processes. And, as before, I can't get cdparanoia to be able to read from the drive until I 'killall kio_audio'.

Just to make sure, I also commented out the 'cd' line in /etc/auto.misc. Still no difference. I'm going to say that autofs is NOT responsible for launching 'kio_audio'. Any idea how I can find out what is?


--------------------
Graham Mitchell, computer science teacher -- Leander High School
Go to the top of the page
 
+Quote Post
dishawjp
post Jun 22 2006, 09:19 AM
Post #4


./configure
***

Group: Members
Posts: 56
Joined: 8-April 04
Member No.: 2,734



I don't have a full answer to your question, but may be able to point you in a direction to look. FC5 is using "gnome-mount" for all this stuff and it's driving me nuts. There are no man pages for gnome-mount, though you can google it for some info. The former "mount" and "umount" commands are deprecated and barely usable for removable media like floppies, optical drives and even usb flashdrives.

HTH,

Jim


--------------------
Registered Linux User 294493
Go to the top of the page
 
+Quote Post
holy Teach
post Jun 24 2006, 10:49 PM
Post #5


Whats this Lie-nix Thing?
*

Group: Members
Posts: 3
Joined: 31-May 06
From: Austin, TX
Member No.: 6,463



I take back my last post. After having commented out the 'cd' line in /etc/auto.misc, kio_audiocd no longer runs when I insert a disc.

I did before, but now that I've rebooted (and a few days later) it just works.

So I can't be certain if that's the difference, or if it's something else I did in the meantime, but my problem is now solved. Thanks for your help!


--------------------
Graham Mitchell, computer science teacher -- Leander High School
Go to the top of the page
 
+Quote Post
DS2K3
post Jun 25 2006, 09:12 AM
Post #6


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,284
Joined: 14-November 04
From: Southampton, Hampshire
Member No.: 4,165



Glad it's sorted

* Closing *

D


--------------------
Fixed your problem? Let us know!
richard@linuxhelp.net

www.Gathr.co.uk Online Event Management
Go to the top of the page
 
+Quote Post

Closed TopicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 10th December 2017 - 07:01 PM