Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
> My kingdom for a wikipad
markjr
post May 30 2006, 08:55 PM
Post #1


./configure
***

Group: Admin
Posts: 62
Joined: 9-February 06
Member No.: 6,054



A few months ago I ditched my win XP laptop and started running an acer with xandros.

It works great, but one think I am missing which I really miss is a functioning wikipad.

So far I've only found this: http://wikidpad.python-hosting.com/wiki/InstallLinux

But I can't seem to get it to work on my system either natively, and the wine instructions don't seem to line up.

CODE
markjr@stuntpope:~/wikipad$ python setup.py
Traceback (most recent call last):
  File "setup.py", line 5, in ?
    import py2exe
ImportError: No module named py2exe


Anyone get this working on Xandros Desktop 3.0.2 Deluxe or know of another linux wikipad to try?
Go to the top of the page
 
+Quote Post
 
Start new topic
Replies (1 - 4)
Ben
post Aug 17 2006, 03:49 PM
Post #2


Whats this Lie-nix Thing?
*

Group: Members
Posts: 1
Joined: 17-August 06
Member No.: 6,996



I find it strange that it's looking to import py2exe on a Linux system.

The Linux installation documents seem to indicate that you can just run Wikipad.py directly, after giving them access to gadfly and pwiki. Try one of the methods in that link and then run 'python Wikipad.py'.

I'm never used the software, so past that I'm not sure.

Cheers.
Go to the top of the page
 
+Quote Post
Hemant
post Aug 28 2006, 05:25 PM
Post #3


RMS is my Hero
******

Group: Support Specialist
Posts: 782
Joined: 6-October 02
From: Trichy,INDIA
Member No.: 29



yes its really strange.But if i were you, i would download the source version of the program and remove the line that does this import of py2exe.

this would solve the problem.


--------------------
Hemant Kumar
user posted image
hemant@linuxhelp.net
Go to the top of the page
 
+Quote Post
markjr
post Jan 30 2007, 10:13 PM
Post #4


./configure
***

Group: Admin
Posts: 62
Joined: 9-February 06
Member No.: 6,054



Well, I finally got this working, but I had to install CrossOver to do it.

Never could get it working native under linux (xandros, debian), got it to the point where I'd get this:

CODE
arkjr@stuntpope:~/wikipad$ python ./WikidPad.py
Traceback (most recent call last):
  File "./WikidPad.py", line 1, in ?
    import WikidPadStarter
  File "/home/markjr/wikipad/WikidPadStarter.py", line 29, in ?
    from pwiki.PersonalWikiFrame import PersonalWikiFrame
  File "/home/markjr/wikipad/lib/pwiki/PersonalWikiFrame.py", line 12, in ?
    import Configuration
  File "lib/pwiki/Configuration.py", line 7, in ?
    from wxPython.wx import wxPlatformInfo
ImportError: cannot import name wxPlatformInfo


I don't seem to have a wxPlatformInfo.py file anywhere, not being a python guy, I suspect this should have been generated but it hasn't been.

Then I tried running it under wine and ran into some other problems.

So I tried CrossOver and after some futzing it works. It took me a couple tries to get it recognizing my old *.wiki files, the trick was to select the sqlite database format. (Be sure to backup your old *.wiki files before you try opening them, because it creates a new empty file if you use the wrong database type and it can't read in the old file)
Go to the top of the page
 
+Quote Post
DS2K3
post Sep 19 2007, 11:57 AM
Post #5


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,284
Joined: 14-November 04
From: Southampton, Hampshire
Member No.: 4,165



I've a feeling wxPython is an extension for making portable GUI apps. A lot of distros seem to ship witout it or at least leave it uninstalled by default though.


--------------------
Fixed your problem? Let us know!
richard@linuxhelp.net

www.Gathr.co.uk Online Event Management
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 22nd November 2017 - 01:45 PM