Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )

Advanced DNS Management
New ZoneEdit. New Managment.


Sign Up Now
Reply to this topicStart new topic
> Using a tape drive
post May 15 2006, 10:52 AM
Post #1


Group: Members
Posts: 29
Joined: 15-July 05
Member No.: 5,271

I'm running SUSE Seerv9 and I'm trying to get data back from a DLT8000 tape drive whichthe server is directly connected via SCSI but I'm not having much joy.

When I use 'mt -f /dev/st0 status' is just reports back 'no such file or directory'

What am I doing wrong?

YAST reports the DLT8000 as being dev/st0

Previously on a older system I just use to use 'mt -f /dev/nst0 rewind and varoius other commands and all worked as it should.
Go to the top of the page
+Quote Post
post May 15 2006, 11:13 AM
Post #2

Its GNU/

Group: Support Specialist
Posts: 1,807
Joined: 23-January 03
Member No.: 360

Either mt is not installed or it is not in your path.

To check you can search via the command.
locate mt
Go to the top of the page
+Quote Post
post May 23 2006, 06:30 AM
Post #3


Group: Members
Posts: 29
Joined: 15-July 05
Member No.: 5,271

I have posted this problem on another forum but haven't had any luck so I thought I'd try here.

Trying to restore an image/file from a tape - done the following:

billy:/amanda # amrestore -p /dev/st0 billy billy._var.20060407.0 | restore -ivf-
Verify tape and initialize maps
Input is from a local file/pipe
amrestore: 0: skipping start of tape: date 20060407 label billy-Full-1-03
amrestore: 1: skipping billy._users_disk11.20060407.0
amrestore: 2: skipping billy._users_disk5.20060407.0
amrestore: 3: skipping billy._users_disk2.20060407.0
amrestore: 4: skipping billy._var.20060407.0
amrestore: 5: skipping billy._users_disk8.20060407.0
amrestore: 6: skipping billy._server_billy_build.20060407.0

I then it just ends. I've dropped the 'b' option as recommended. I want to restore the image to the CWD (which has plenty of space) not a sda1 or sdb2 etc etc. It just seems to skip past everything.

I want to restore the file 'billy._var.20060407.0'

So I then try:

billy:/amanda # tar xvf /dev/st0 billy._.20060407.0
tar: /dev/st0: Cannot read: Cannot allocate memory
tar: At beginning of tape, quitting now
tar: Error is not recoverable: exiting now


I have now tried all sorts. I can forward to the file I want by using 'mt -f /dev/tape fsf 14' having got the file number by doing ' amrestore -p /dev/st0 no-such-host > /dev/null'
I've tried 'tar xvf /dev/st0 billy._disk1.20060407.0'
I've tried 'dd if=/dev/tape bs=32k | tar xvf -'
I've tried 'amrestore -p /dev/st0 billy._disk1.20060407.0 | tar xvf -'
I've tried 'amrestore -p /dev/st0 billy._usr.20060407.0 | restore ivbf 2 -'
And 'amrestore -p /dev/st0 billy._usr.20060407.0 | tar -xvf - ./amanda'

The problem seems that whatever I do it just merrily skips on past the file.

What I don't get is that I'm using 'mt -f /dev/st0 fsf 14 to skip past the other files so it doesn't spend ages seeking yet it always seems to reoprt back from the first file and tediously goes through the whole tape again - why? It skips to 14 (or appears to be) then it should start listing/finding tec from 14, not start from 0 all over again. What am I doing wrong?
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:


RSS Lo-Fi Version Time is now: 19th July 2018 - 02:17 PM