Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> postfix, mysql,courier-imap on fedora 5
Guest_mmoor_*
post May 13 2006, 04:22 PM
Post #1





Guests






Okay i need help smile.gif
Buyed 3 books but still dont work..

I have:
mysql v4.1.19 8Server, client, bench, etc)
postfix v2.2.10

make -f Makefile.ini makefiles 'CCARGS=-DHS_MYSQL -I/usr/lib/include' 'AUXLIB=-L/usr/lib/mysql -lmysqlclient -ls -lm'
make
make install

<postconf -m

dosent list mysql

try to install courier-imap 1.4.4
says faild on authmysql

Any help is welcome
Go to the top of the page
 
+Quote Post
Termina
post May 14 2006, 11:34 AM
Post #2


RMS is my Hero
******

Group: Support Specialist
Posts: 862
Joined: 18-February 04
From: Wisconsin
Member No.: 2,404



You didn't give us much information, but I'll try to help.

Are you trying to set up postfix to use virtual users from mysql?

What have you added to main.cf? (can you upload it somewhere, and give us a link?)

Do you have virtual_alias_maps and virtual_mailbox_* set up correctly?

Also, did you make sure authdameonrc is using 'authmysql'? Is courier-authmysql even installed?

Some more information would be much more helpful...


--------------------
*Points finger at the author above him* They're a witch! Burn them!
---
Vist my website!
Join me in IRC! Server: st0rage.org Channel: #UnhandledExceptions
Go to the top of the page
 
+Quote Post
Guest_mmoor_*
post May 14 2006, 03:46 PM
Post #3





Guests






got postfix compiled with mysql.. that works now..

but still no success on courier-imap-1.5.3

call
./configure --with-mysql-libs=/usr/lib/mysql4/mysql --with-mysql-includes=/usr/include/mysql4/mysql --with-authmysql

[..]
checking for mysql_config... (cached) /usr/bin/mysql_config
checking for mysql_connect... (cached) no
configure: error: --with-authmysql specifed but no mysqlclient.so
configure: error: ./configure failed for authlib

And there configure stops.
--------
I have installed:
mysql server 4.1.19-Standart-log
mysql client 5.1.7
mysqlclient3, mysqlclient4, both including devel.
courier-authlib-mysql 0.58-1.5.i386.
mysql-bench 4.1.19-0
mysql-devel 4.1.19
mysql-shared 4.1.19
mysql-shared-standart 4.1.19
mysql-standart-debuginfo 4.1.19
Go to the top of the page
 
+Quote Post
Termina
post May 14 2006, 08:59 PM
Post #4


RMS is my Hero
******

Group: Support Specialist
Posts: 862
Joined: 18-February 04
From: Wisconsin
Member No.: 2,404



That's strange, that it cannot find mysqlclient.so. Have you tried updatedb && locate mysqlclient.so?

You may just need to copy it to the current dir, or run ldconfig.

Is there a reason you're compiling instead of using rebuilt packages? What distro do you use?


--------------------
*Points finger at the author above him* They're a witch! Burn them!
---
Vist my website!
Join me in IRC! Server: st0rage.org Channel: #UnhandledExceptions
Go to the top of the page
 
+Quote Post
Guest_mmoor_*
post May 15 2006, 05:36 AM
Post #5





Guests






Nope i dont think there is any reason why i compile ? But since im a complet noob in linux my 4 day i fumble on it. thats my a good question. smile.gif

Fedora 5, but could not find any rpm packages for fedora, and have to say soon i lose my marbeles smile.gif

Yep no mysqlclient.so not on the entry drive..
just
libmysqlclient_r.so
libmysqlclient_14_r.so
and stuff like that
Go to the top of the page
 
+Quote Post
Termina
post May 15 2006, 11:12 PM
Post #6


RMS is my Hero
******

Group: Support Specialist
Posts: 862
Joined: 18-February 04
From: Wisconsin
Member No.: 2,404



Chances are you compiled mysql wrong, then. sad.gif

I really suggest you find a good mirror, after you 'make uninstall' all your current stuff.

Using recompiled binaries makes it much easier to install and upgrade.

Remember: If you compile, you're going to have to recompile everytime you want to upgrade.


--------------------
*Points finger at the author above him* They're a witch! Burn them!
---
Vist my website!
Join me in IRC! Server: st0rage.org Channel: #UnhandledExceptions
Go to the top of the page
 
+Quote Post
Guest_mmoor_*
post May 16 2006, 05:44 AM
Post #7





Guests






yepers.. well gave up..

Now i have postfix runing and vm-pop3d .. that works great..

Dont think it was mysql, becouse websites what using mysql where runing great.
Go to the top of the page
 
+Quote Post
Guest_mmoor_*
post May 17 2006, 09:22 AM
Post #8





Guests






talked to erlay.. vm-pop is goofy also.

Cant pick up mail via netscape mail, via outlock it works until today.
Now I get an error: (The RETR command did not succed. Error retrieving a message. Mail server xx.xx.xx responded: libc detected *** vm-pop3d: munmap_chunk(): invalid pointer: 0x095663400 ***)

After reinstall new.. I get in netscape mail. (Folders get processed. pls wait until this is done to get emails.)

Since im a complet newbie, another question is there somewhere a easy to install and configure pop server out what handels virtual mailboxes ?
Go to the top of the page
 
+Quote Post
Termina
post May 17 2006, 10:47 AM
Post #9


RMS is my Hero
******

Group: Support Specialist
Posts: 862
Joined: 18-February 04
From: Wisconsin
Member No.: 2,404



Here's a great article about the kind of set up you want.

It's for Debian stable, BTW.

http://workaround.org/articles/ispmail-sarge/


--------------------
*Points finger at the author above him* They're a witch! Burn them!
---
Vist my website!
Join me in IRC! Server: st0rage.org Channel: #UnhandledExceptions
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 20th October 2017 - 04:43 PM