Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> crontab permission, user unable to execute crontab
adamwer
post May 11 2006, 11:15 AM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 5
Joined: 11-May 06
Member No.: 6,361



Hi
System: PLD Linux 2.6.8, vixie-cron. While installing gnats I encountered the following:

[root@sierra ~]# cd /home/users/gnats
[root@sierra gnats]# su gnats
[gnats@sierra ~]$ ls -altr
total 28
...
-rw-r--r-- 1 gnats users 64 May 9 15:28 .mycron
...
[gnats@sierra ~]$ crontab .mycron
You (gnats) are not allowed to use this program (crontab)
See crontab(1) for more information
[gnats@sierra ~]$

I checked the files below several times:
/etc/cron/cron.allow
/etc/cron/cron.deny
Additionaly I created (with the same attributes):
/etc/cron/at.allow
/var/spool/cron/at.allow
/var/spool/cron/cron.allow

Finally I tried:
chmod a+rwx /etc/cron.d/crontab

Still the same error.
I will appreciate any hint.

Cheers
Adam
Go to the top of the page
 
+Quote Post
Termina
post May 14 2006, 11:42 AM
Post #2


RMS is my Hero
******

Group: Support Specialist
Posts: 862
Joined: 18-February 04
From: Wisconsin
Member No.: 2,404



That's pretty strange. Here are some ideas.

Does plain old 'crontab -e' give you that same error?

You say you checked /etc/cron.allow/deny; are they empty? I believe that, if cron.allow is created, users that want to use crontab MUST be listed there.

Perhaps something in there is causing the problem, could you show us the contents?

I see you changed the permission of /etc/cron.d/crontab, but have you done the same with .mycron?


--------------------
*Points finger at the author above him* They're a witch! Burn them!
---
Vist my website!
Join me in IRC! Server: st0rage.org Channel: #UnhandledExceptions
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 24th October 2017 - 06:35 AM