Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> Error booting after upgrading Kernel
scratched
post Mar 24 2006, 03:14 PM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 2
Joined: 24-March 06
Member No.: 6,204



I'm new to linux and I just installed ubuntu 5.10 on an external hard drive. I got it to run without a hitch, then I upgraded to the latest kernel and tried restarting. I got to the GRUB screen, selected ubuntu, and then I got this error:

CODE
root (hd1,1)
Filesystem type unknown, partition type 0x7
kernel /boot/vmlinuz-2.6.12-10-386 root=/dev/sda2 ro quiet splash

Error 17: Cannont Mount Selected partition.


I have ubuntu installed on the second partition of my USB hard drive so the root is in (hd1,1) (at least I think it is. like I said I'm new to linux so this is somewhat foreign to me), and I reinstalled GRUB since it looked like other people have had that problem, but as far as I can tell, I re-installed grub properly and it didn't fix it. I can boot to windows, and I can boot with a knoppix or ubunutu live CD. The old kernel is still listed in GRUB and I've tried selecting that but I get the same error.

Does anyone know what this problem is and how I can fix it? I'm a newbie when it comes to linux so I really have no idea what the problem is.
Go to the top of the page
 
+Quote Post
Termina
post Mar 26 2006, 07:54 PM
Post #2


RMS is my Hero
******

Group: Support Specialist
Posts: 862
Joined: 18-February 04
From: Wisconsin
Member No.: 2,404



When you upgrade the kernel with Ubuntu, it should have added a new entry in grub.

Use the Ubuntu Live CD, mount your partition, and make sure /boot/vmlinuz-2.6.12-10-386 exists


--------------------
*Points finger at the author above him* They're a witch! Burn them!
---
Vist my website!
Join me in IRC! Server: st0rage.org Channel: #UnhandledExceptions
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 20th October 2017 - 10:09 PM