Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> Apache Help - 403 Forbidden, Using a smb mount in html folder for web
Katari
post Mar 10 2006, 01:43 PM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 1
Joined: 10-March 06
Member No.: 6,138



All:

I appreciate any help in this matter. Myself and multiple admins can't seem to come up. We are running an apache web server using redhat advanced server. We are running an intranet on our server and we created a smb mount to another windows share and then we put that mount in a subdirectory of our html folder for apache (/var/www/html). We are calling it dasdshare. The problem is when we try to access it via the website we get the following error:

You don't have permission to access /dasdshare on this server.

Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.

We did a chmod 777 on it already and the only difference I can see in this folder and the other folders we have that are working is the other persmissions are
drwxr-xr-x 2 root root 4096 Mar 8 17:11 web

and the one that isn't working is
drwxr-xr-x 1 root root 4096 Mar 9 12:35 dasdshare

I don't know if the 2 root root vs 1 root root makes a difference.

Beers on me if you guys can help

Thanks.
Go to the top of the page
 
+Quote Post
as2100
post Mar 10 2006, 03:25 PM
Post #2


Grub-er
**

Group: Members
Posts: 26
Joined: 27-January 05
Member No.: 4,595



Can you post the permissions for a couple files (specifically the index) that are under the /dasdshare directory? The directory looks to have correct permissions, but how about the files in dasdshare that actually need to be read?

Also, type 'mount' and post what permissions your SMB mount was mounted with.
Go to the top of the page
 
+Quote Post
DS2K3
post Mar 10 2006, 05:28 PM
Post #3


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,284
Joined: 14-November 04
From: Southampton, Hampshire
Member No.: 4,165



SMB shares sometiumes need to be mounted with the "user" option, and "umask=0777" to give users the correct permissions (777 might seem dangerous, but bear in mind that Windows Filesystems dont have any file permission support - and read-only supported can be setup on the server)

D


--------------------
Fixed your problem? Let us know!
richard@linuxhelp.net

www.Gathr.co.uk Online Event Management
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 18th December 2017 - 09:53 AM