Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Closed TopicStart new topic
> Weird Gentoo Network Problem
DS2K3
post Feb 14 2006, 08:56 AM
Post #1


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,284
Joined: 14-November 04
From: Southampton, Hampshire
Member No.: 4,165



I have a slightly strange problem with my Gentoo server, and two network interfaces.

Basically, I wanted to connect another computer directly to the server, so "that will be easy" i though - "I'll just enable the interface which i'm not using at the moment". 'Cept it didnt work like that.

I configured the interface (eth1) in /etc/conf.d/net as follows
CODE
# /etc/conf.d/net:
# $Header: /home/cvsroot/gentoo-src/rc-scripts/etc/conf.d/net,v 1.7 2002/11/18 $

# Global config file for net.* rc-scripts

# This is basically the ifconfig argument without the ifconfig $iface
#
iface_eth0="10.0.0.1 broadcast 10.0.0.255 netmask 255.0.0.0"
iface_eth1="10.0.0.4 broadcast 10.0.0.255 netmask 255.0.0.0"

# For setting the default gateway
gateway="eth0/10.0.0.2"


Then, I copied /etc/init.d/net.eth0 to /etc/init.d/net.eth1 (like the Gentoo docs say you need to, and like i have done numerous times before). All was OK so far. So I ran the net.eth1 script, and started the interface.

Then it got weird. I couldnt ping 10.0.0.4 from the computer connected directly to eth1, but I could ping it from the network connected to eth0 (10.0.0.1). Ifconfig confirmed that both interfaces had the correct IP.

So, I disabled the interface. Unfortunately, the server still responds to pings, http requests and absolutely everything else on 10.0.0.4! I even removed it from the config file, to no avail!

It seems that it's getting eth0 and eth1 confused somehow, and giving both IPs to the same physical interface (depsite the fact that ifconfig clearly shows that they have different hardware addresses). No idea why it wont give up the Ip address - I restarted all the service that depend on it, so I dont tihk it is one of those blocking it.

Any ideas?

D


--------------------
Fixed your problem? Let us know!
richard@linuxhelp.net

www.Gathr.co.uk Online Event Management
Go to the top of the page
 
+Quote Post
Robert83
post Feb 14 2006, 11:44 AM
Post #2


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,439
Joined: 3-January 04
From: Germany
Member No.: 2,069



Hi,

just a idea :

/etc/init.d/net.eth0

is there a entry for the cards mac address? (eth0 mac address)

Sincerely
Robert B


--------------------
Robert Becskei
robert83@linuxhelp.net
--------------------
May the source be with us!
--------------------
AMD X2-3800 @ 2400Mhz
2048MB DDR 400Mhz
DFI Lanparty UT4 NF4 ULTRA-D
GeForce 7800GT
250GB+250GB
Pioneer DVD-RW
17inch Samsung Syncmaster 757NF
WinXP Pro (SP2)/ CentOS 4.3
--------------------
Go to the top of the page
 
+Quote Post
DS2K3
post Feb 14 2006, 11:58 AM
Post #3


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,284
Joined: 14-November 04
From: Southampton, Hampshire
Member No.: 4,165



Don't think so.

Anyway, I rebooted to get rid of the IP adresses it had accumulated, and then stuck the two interfaces on different subnets. I guess it could be a bug with part of the network setup (it's pretty much default settings) but I dont have the time or know-how to figure out what's wrong with it atm.

i saw somebody else had the same problem as me on the Gentoo forums, but that was 2004 and there were no replies.

Anyway, it' working now - Thanks for replying

* Closing *

D


--------------------
Fixed your problem? Let us know!
richard@linuxhelp.net

www.Gathr.co.uk Online Event Management
Go to the top of the page
 
+Quote Post

Closed TopicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 20th October 2017 - 02:58 PM