Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> Firefox won't start in SuSe 10, Gives an error and doesn't open
marcel98
post Jan 5 2006, 10:21 AM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 1
Joined: 5-January 06
Member No.: 5,937



I use Firefox since version 0.10.
Recently I upgraded from Firefox 1.0.7 to 1.5 running on Suse 9.3.
Then I upgraded from Suse 9.3 to Suse 10.
After that, Firefox 1.5 ran only once then crashed.
From this moment on, every time I try to start Firefox (any version, I tried with 1.0.6, 1.0.7, 1.5 and the still beta 1.6) I get this error messages:

(firefox-bin:10732): GConf-WARNING **: Wrong permissions for /tmp/gconfd-root, or it is not a directory

** (firefox-bin:10732): WARNING **: Wrong permissions for /tmp/orbit-root

*** loading the extensions datasource

(firefox-bin:10732): GConf-WARNING **: Wrong permissions for /tmp/gconfd-root, or it is not a directory

** (firefox-bin:10732): WARNING **: Wrong permissions for /tmp/orbit-root

(at this point Firefox briefly - less than a second - opens it window and then vanish)

*** loading the extensions datasource
The program 'Gecko' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadDrawable (invalid Pixmap or Window parameter)'.
(Details: serial 1420 error_code 9 request_code 70 minor_code 0)
(Note to programmers: normally, X errors are reported asynchronously;
that is, you will receive the error a while after causing it.
To debug your program, run it with the --sync command line
option to change this behavior. You can then get a meaningful
backtrace from your debugger if you break on the gdk_x_error() function.)

I already tried to remove the Firefox dir inside .mozilla, remove all instances of Firefox on the system, including temp files and install dirs. Then downloading and installing a fresh install. Nothing works.

I run Suse 10 with KDE.

Any ideas?
Go to the top of the page
 
+Quote Post
DS2K3
post Jan 5 2006, 02:54 PM
Post #2


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,284
Joined: 14-November 04
From: Southampton, Hampshire
Member No.: 4,165



Upgrades tend to be messy and leave a lot of rough edges. You might have some incompatible libraries lying around, or something might have got corrupted. Ther are a lot of reasons that a program could crash, and the errors which are being thrown up downt give any real clue as to why they're occurring. Check that you ahve the most recent version of X installed (how did you isntlal firefox - Suse-packaged or an official build?).

Failing that, try a fresh install of Suse 10 to see if that fixes the problem.

D


--------------------
Fixed your problem? Let us know!
richard@linuxhelp.net

www.Gathr.co.uk Online Event Management
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 20th October 2017 - 04:41 PM