Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> Linux File Copy, Copy Files from linux to windows
dudeking
post Dec 23 2005, 10:01 AM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 1
Joined: 23-December 05
Member No.: 5,889



Right to give the full story hereís what happened...

...I had windows XP installed on my pc on an 80GB Hard Disk. I then used partition magic to shrink that down to a 70GB partition, and created a 10GB partition which I then installed slackware Linux on. The instillation went well (except failing to successfully write to the MBR, so I created a boot disk on a Floppy disk.) and Linux worked. I ran Linux for around 30mins when I decided to check to see if windows XP was still working. After restarting my pc and removing my Linux boot disk I was given the error 'NTLDR is corrupt or missing'. I then restarted with my XP CD in drive D and booted from it. I ran the recovery console and followed several guides on the internet to fix the error (which just changed the error I was given) e.g. writing a new boot sector, MBR and replacing several .dll's. None of these worked so I was forced to reinstall windows. So I booted Linux up and created a folder called 'Backup' in the root folder. I then copied every thing I wanted to keep off my windows installation e.g. Documents and Settings, Emails and Game Settings into it. The 2.9GB of files copied successfully. So I deleted the 70GB Windows partition, created a new one over it and formatted it using the NTFS file system. I installed windows XP.

************
Now My problem...

...I cannot copy my files back from Linux to windows. I have tried using pen drives (says cannot create directory (or summing similar)). Burning to CD... Canít work out how to install the software (K3B) (I have never used Linux before I donít really know how it works). I donít care about any of the files except the 2.9GB that I need to save. I donít need any of the OS's they can be reinstalled I just need the files.
************

If any one can help me please do. Iíve been trying to solve the problem for a week now.

Thanks Eddie
Go to the top of the page
 
+Quote Post
cagey cretin
post Dec 23 2005, 10:43 AM
Post #2


./configure
***

Group: Members
Posts: 96
Joined: 9-September 03
Member No.: 1,413



Please show us your partitions by running as root:

CODE
fdisk /dev/hda
command (m for help): p


This will print the partition table. Note which one is the Windows partition. You'll see which one it is. My output on this machine:
CODE
Command (m for help): p

Disk /dev/hda: 6448 MB, 6448619520 bytes
255 heads, 63 sectors/track, 784 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

  Device Boot    Start       End    Blocks   Id  System
/dev/hda1   *         1        96    771088+   b  Win95 FAT32
/dev/hda2            97       224   1028160    5  Extended
/dev/hda3           225       734   4096575   83  Linux
/dev/hda4           735       779    361462+  82  Linux swap
/dev/hda5            97       224   1028128+   6  FAT16


Let's say I wanted to copy whatever files to C:Linux_files. that maps to my partition /dev/hda1 If I wanted to copy files to the windows partition, I would do the following.

Run as root:
CODE
mkdir /mnt/linux_to_save
mount /dev/hda1 /mnt/linux_to_save
mkdir /mnt/linux_to_save/Linux_files #Makes directory on windows called Linux_files
cp /path/to/your/files/to/copy  /mnt/linux_to_save/Linux_files # You've just copied files to that windows directory
umount /dev/hda1 /mnt/linux_to_save


Reboot into windows and check.
Go to the top of the page
 
+Quote Post
michaelk
post Dec 25 2005, 12:30 PM
Post #3


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,797
Joined: 23-January 03
Member No.: 360



You do not mention what distribution you installed but typically writing to NTFS is not recommended and some distros only include read support.

Typically pen drives are preformated as FAT32 which linux and XP fully supports for reading and writing. You might not have write support as a regular user which can be changed by modifing the /etc/fstab file and adding the umask=000 option. Typical example

/dev/sda1 /media/flash vfat users,umask=000 0 0

The mount point can be any directory but it needs to exist.
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 19th October 2017 - 05:06 PM