Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> IBM eSeries x226 boot floppy, will not boot to lilo or grub floppy
Cadstar
post Dec 8 2005, 03:42 PM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 1
Joined: 8-December 05
Member No.: 5,837



OK, this is an odd one:

Been building/admining IBM servers for several years now, all running RedHat 7.3. I always create a boot floppy using grub-install in case of any problems such as blown-out boot sector on hard drive, ect. I have never run into an issue with booting an IBM eServer from the grub floppies. Recently started using the x226 server (8648-1AU) and discovered it WILL NOT boot to my grub-install floppies. It will boot a syslinux floppy, an MS-DOS floppy, and it will even boot to a grub prompt if I manually create a bootable grub floppy like so:
cd /boot/grub
dd if=stage1 of=/dev/fd0 bs=512 count=1
dd if=stage2 of=/dev/fd0 bs=512 seek=1

The grub-install utility (which I use to boot if the HD boot sector gets blow away) creates the disk with no errors reported (and it will WILL boot in ANY other machine I try it on) but the IBM refuses to read it's boot sector. I get a 1962 Operating System not found error every time. I have tried the following to resolve this:
1- different brand of floppy
2- different brand of floppy drive, different floppy cable
3- newer grub version (normally I use 0.91, have updated to 0.94)
4- made a lilo boot disk (doesn't work either)
5- updated server BIOS to latest version
6- contacted IBM tech support - they are clueless
7- searching the web for a week for some idea of what may be going on
8- tried several (about 7) different x226 machines

It seems to me there must be an issue with the firmware in the mainboard chipset but I can find no record anywhere of anyone else having such a problem. It's kind of a long shot but I decided to post here and see if anyone has some kind of idea what may be happening or how to troubleshoot the issue further.

Thanks in advance for any help anyone can provide.

-Cadstar
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 14th December 2017 - 10:18 AM