Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> New Linux User - Ftp Problem
mellewis
post Nov 28 2005, 08:20 AM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 1
Joined: 28-November 05
Member No.: 5,789



Hi

i have just taken over a dedicated server running Fedora Core 3. The server has a 80GB HDD. I know very little about Linux.

We are uploading about 15 GB of aerial photography images to the server in three files sizes to 3 folders - imagessml, imagesmed and imageslge. I have found that I can only upload 1998 files to each folder which is a problem as there are over 6000 images for each folder waiting to go up.

If I try to upload more than the 1998 files, they appear to upload properly but do not show on the server. As the three file sizes range from 4k to 2.5mb, it has nothing apparently to do with a maximum folder size (in MB).

Does anyone know why this is happening and what to do about it? I have spoken to the ISP but they seem to be a little confused by the problem. If I can point them in the right direction, they may fix it quicker.

thanks very much

Mel Lewis
Go to the top of the page
 
+Quote Post
cagey cretin
post Nov 28 2005, 11:06 AM
Post #2


./configure
***

Group: Members
Posts: 96
Joined: 9-September 03
Member No.: 1,413



You could always zip a bunch of the files together into smaller batches which will 1) reduce the number of files in the ftp folder and 2) reduce data transfer (you are compressing the files).
Go to the top of the page
 
+Quote Post
DS2K3
post Nov 28 2005, 11:24 AM
Post #3


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,284
Joined: 14-November 04
From: Southampton, Hampshire
Member No.: 4,165



BUt it you zip them, you have to go to the trouble of unzipping them before they can be used. I have a feeling it might be something to do with the maximum number of inodes available for a given directory.

How do the files "not show up"? Weird question, but if it's just that they dont show up on the server-generated index page, but do show up via FTP, then maybe the web server just wont index more than 1998 files. Try requesting a single image that doesnt show up in the list if you havent already.

D


--------------------
Fixed your problem? Let us know!
richard@linuxhelp.net

www.Gathr.co.uk Online Event Management
Go to the top of the page
 
+Quote Post
Jim
post Nov 28 2005, 12:32 PM
Post #4


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,280
Joined: 19-November 03
From: University of Minnesota- TC
Member No.: 1,828



What filesystem are you using? It is completely possible to write more files into a folder then the folder can 'hold' and that size depends on the file system.

I think that switching filesystems isn't the option you want to go with, so I would suggest just making multiple folders

imagessml_1 imagessml_2 and such or what ever.

That is the simplest solution to this problem.


--------------------
--Jim Lester
jim@linuxhelp.net

Distro: Gentoo
System: AMD Athlon 3000+ XP 2.166 GHz
NVIDIA nForce2 IGP Chipset
1GB 333 MHz DDR SDRAM
NVIDIA nForce2 Dual Head 64 MB Graphics

Server Distro: CentOS
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 17th October 2017 - 02:56 AM