Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> samba question, how to share a linux drive on a win net
WhiteSpyder
post Apr 1 2003, 04:56 PM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 3
Joined: 1-April 03
Member No.: 616



I am trying to get 3 hard drives on my linux box to share under my works windows network. I have set the smb.conf file to share the directories I want shared, but I don't know how to get the shares recognized under windows. When I look at it in My Network Places, It shows up as a server of its own, MDKGROUP, with the computer "LOCALHOST". I would like the linux shares to be under my work's workgroup, which we will call "apple". So what I want to do is to have someone out there send me a sample smb.conf file with this information, so that I can do the smae on my computer. Also, when I try to look at the share under windows, it says I do not have permission to log on, or that I have the incorrect username or password. Could this be because of encrypted passwords? I am in the dark right now, and any help would be appreciated.
Go to the top of the page
 
+Quote Post
frodo44
post Apr 1 2003, 07:31 PM
Post #2


./configure
***

Group: Members
Posts: 95
Joined: 2-December 02
Member No.: 213



under the [Global] tag put the following line:

workgroup = the name of your work group

Hope this helps. If not, you may be in for a long dance of the Samba...

Eric


--------------------
Windows XP; Debian 3.0r2 (Woody)
---
Shuttle AK32 Mobo w/ Athlon XP 1700+ @ 266 FSB
GeForce 4 mx440 64mb
Turtle Beach Santa Cruz 5.1 Surround Sound
256 MB DDRAM
Seagate 80gb, Western Digital 40gb
---
weezle@charter.net
Go to the top of the page
 
+Quote Post
etshooter
post Apr 1 2003, 09:31 PM
Post #3


Whats this Lie-nix Thing?
*

Group: Members
Posts: 15
Joined: 28-February 03
Member No.: 498



Don't forget to add users and passwords to the smbpasswd file. You need to add these for all users that need access to these shares. Add them either through SWAT or in a terminal (instructions can be had by typing "man smbpasswd"(no quotes) in the terminal window).
Also watch out for your firewall settings. These had me baffled for weeks before I got connectivity.


--------------------
Mandrake Linux 9.1
1.33Ghz Athlon T-bird
64MB ATI Radeon7000
256MB PC133
30 GB WesternDigital HD
1 Clueless dork on the keyboard
Go to the top of the page
 
+Quote Post
WhiteSpyder
post Apr 2 2003, 07:30 PM
Post #4


Whats this Lie-nix Thing?
*

Group: Members
Posts: 3
Joined: 1-April 03
Member No.: 616



I set the workgroup correctly, and managed to get the comp recognized under win. My problem now, is users and passwords. After extensive reading of the man pages for passwd and smbpasswd, I was able to add my username to the smbpasswd file, set a password for that username, and access the comp through windows with that username & pass. What I want to do, however, is have it so that all of the people at my work (about 25) can access the computer without having to create new usernames and passwords on my linux box. Is there a way to set smb.conf so that it checks the network list of users and passwords instead of creating its own list. A reply on this topic would be very beneficial. Thanks for what info you guys have already posted, too.
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 23rd October 2017 - 07:30 PM