Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> I Need Help Please$@!$##@$
bmcog
post Nov 10 2005, 09:28 PM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 4
Joined: 10-November 05
Member No.: 5,727



My problem may sound quite simple for the experienced linux user but I am not... I am in need of some advice. I have 2 physical eth cards in one machine cabled to 2 linksys routers one for each eth I am trying to get my vsftpd working on one provider and my httpd working on the other router both have there own static ip... I have the address for the cards at 192.168.1.8 for my ftp server and 192.168.1.7 for my httpd... I have set the line in the vsftpd.conf to listen_address=192.168.1.8 but it still cant be reached.. however I can change the gateway on the ftp router to 192.168.1.254
instead of 192.168.1.1 whhich is the same as my httpd router gateway and the ftp server begins to be seen and works... but my httpd server can no longer be found..

if someone could help please
my route is as follows

destination gateway genmask flags metric ref use iface
192.168.1.0 * 255.255.255.0 u 0 0 0 eth0
192.168.1.0 * 255.255.255.0 u 0 0 0 eth1
169.254.0.0 * 255.255.0.0 u 0 0 0 eth1
default 192.168.1.1 0.0.0.0 ug 0 0 0 eth0
Go to the top of the page
 
+Quote Post
michaelk
post Nov 11 2005, 09:47 AM
Post #2


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,797
Joined: 23-January 03
Member No.: 360



Change one of your ethernet card / router subnet to something other then 192.168.1.x i.e. 192.168.2.x
Go to the top of the page
 
+Quote Post
bmcog
post Nov 11 2005, 04:48 PM
Post #3


Whats this Lie-nix Thing?
*

Group: Members
Posts: 4
Joined: 10-November 05
Member No.: 5,727



ok tried this,, Changed the linksys router configuration to 192.168.2.1
set my eth1 on 192.168.2.8 opened up the port to see 192.168.2.8 on the ftp port 21 set my vsftpd.conf to listen_address=192.168.2.8 once again the ftp would work but my httpd quit working.... I could view my web pages this time from withen my local domain. but when i tried to view them from a remote pc it would not allow me to.... I did notice that now when I log on to the Internet from the linux box it is pulling the static ip from my eth1 card and no longer my eth0 when this was changed...

I did check all my firewall settings and even disabled them while i was testing

anymore suggestions
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 22nd October 2017 - 08:58 AM