Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )

Advanced DNS Management
New ZoneEdit. New Managment.


Sign Up Now
> External Serial Fax/modem, US Robotics Sporster 33.6 Serial Fax/Mod
post Nov 10 2005, 04:25 PM
Post #1

Whats this Lie-nix Thing?

Group: Members
Posts: 2
Joined: 10-November 05
Member No.: 5,725

Here is my problem:
I have a US Robotics Sporster 33.6 External Serial Modem And I'm trying to run it on Fedora Core 4. After reading the HowTo-Modem serveral times I'm stumped.

Using Fedora Core's Network Configuration (in gnome) it cannot find the modem (even when I manual enter it's location and settings), to be a bit more specific it says Initalizing Modem... and hangs indefinitely.

kppp can find the modem... but I have yet to successfully dial with it... not sure what the problem is there. it always hangs and gives a sequence error.

Ussing wvdial, I can get it to dial, but I cannot get it to negotiate the connection. (Never authenticates)

I have taken a lot of steps... about 4 hrs worth... to fix this... and I'll wager (am hoping) it is something simple.

Here is what I'd like to do:
I'd like to get the Network Configuration tool to work... however I would be content to use kppp or even wvdial
if that was the only way I could connect.

Here is the wvdial.conf file I have... (minus ISP phone, user and pass of course)
    [Dialer Defaults]
    Modem = /dev/ttyS0
    Baud = 115200
    Init1 = ATZ
    Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
    ISDN = 0
    Modem Type = Analog Modem
    Phone = <ISP Phone Here>
    Username = <User Name here>
    Password = <Password here>

This will get the modem to dial, and handshake with the ISP, but then I get the following
(and because I'm sure someone will not notice, I did remove the phone from the log and replaced
it with <ISP Phone Here>... it is not actually trying to dial a string sequence):
    [root@WhamBall ~]# wvdial
    --> WvDial: Internet dialer version 1.54.0
    --> Initializing modem.
    --> Sending: ATZ
    --> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
    --> Modem initialized.
    --> Sending: ATDT<ISP Phone Here>
    --> Waiting for carrier.
    ATDT<ISP Phone Here>
    CONNECT 26400/ARQ
    --> Carrier detected.  Waiting for prompt.
    --> Don't know what to do!  Starting pppd and hoping for the best.
    --> Starting pppd at Thu Nov 10 17:45:09 2005
    --> pid of pppd: 2483
    --> Using interface ppp0
    --> Disconnecting at Thu Nov 10 17:45:31 2005
    --> The PPP daemon has died: A modem hung up the phone (exit code = 16)
    --> man pppd explains pppd error codes in more detail.
    --> Try again and look into /var/log/messages and the wvdial and pppd man pages for more information.
    --> Auto Reconnect will be attempted in 5 seconds

I looked up the code in the man pppd pages... and the code was rather ambiguous... "The link was terminated by the modem hanging up".

I have tried various settings for the DIP switches on the back, I have tried to turn Carry detect to go with
connection and to force Carry Detect on...

Incase anyone is wondering here are the DIP Switch Positions I presently have (I have tried many many combinations up to now..)
{Indicates selected switch possition}
Switch 1 Data terminal Ready {Normal} - Override
Switch 2 Result Codes type {Numeric} - Verbal
Switch 3 Result Codes {Suprress} - Display
Switch 4 Echo offline commands {No Echo offline commands} - Echo Offline commands
Switch 5 Auto Answer {off} - on
Switch 6 Carry Detect {Override} - Normal
Switch 7 Defaults {Factory Defaults} - NVRam Defaults
Switch 8 Mode {Smart} - Dumb

Here is the info on the box (at least the parts I think are important):
CPU: 1.0 Ghz AMD
Ram: 384 MB
Serial Ports: 1 (on motherboard)

The following were requested in the first post in hardware (recomended info)

dmessage (Parts)
    Linux version 2.6.11-1.1369_FC4
    Serial: 8250/16550 driver $Revision: 1.90 $ 76 ports, IRQ sharing enabled
    ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
    ttyS1 at I/O 0x2f8 (irq = 3) is a 16550A

tail -f /var/logs/messages

    Nov 10 16:37:47 localhost nmbd[1894]:    
    Nov 10 16:37:47 localhost nmbd[1894]:   Samba name server WHAMBALL is now a local master browser for workgroup WORKGROUP on subnet
    Nov 10 16:37:47 localhost nmbd[1894]:    
    Nov 10 16:37:47 localhost nmbd[1894]:   *****
    Nov 10 17:01:01 localhost crond(pam_unix)[2450]: session opened for user root by (uid=0)
    Nov 10 17:01:02 localhost crond(pam_unix)[2450]: session closed for user root
    Nov 10 17:06:52 localhost gpm[1854]: *** info [mice.c(1766)]:
    Nov 10 17:06:52 localhost gpm[1854]: imps2: Auto-detected intellimouse PS/2
    Nov 10 17:06:56 localhost login(pam_unix)[1965]: session opened for user root by (uid=0)
    Nov 10 17:06:56 localhost  -- root[1965]: ROOT LOGIN ON tty1


    Module                  Size  Used by
    autofs4                29253  2
    sunrpc                167813  1
    md5                     4033  1
    ipv6                  268097  8
    uhci_hcd               35152  0
    parport_pc             28933  0
    parport                40585  1 parport_pc
    i2c_viapro              8017  0
    i2c_core               21569  1 i2c_viapro
    snd_via82xx            30081  0
    gameport               18633  1 snd_via82xx
    snd_ac97_codec         75961  1 snd_via82xx
    snd_seq_dummy           3653  0
    snd_seq_oss            37057  0
    snd_seq_midi_event      9153  1 snd_seq_oss
    snd_seq                62289  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
    snd_pcm_oss            51185  0
    snd_mixer_oss          17857  1 snd_pcm_oss
    snd_pcm               100169  3 snd_via82xx,snd_ac97_codec,snd_pcm_oss
    snd_timer              33605  2 snd_seq,snd_pcm
    snd_page_alloc          9669  2 snd_via82xx,snd_pcm
    snd_mpu401_uart        10049  1 snd_via82xx
    snd_rawmidi            30305  1 snd_mpu401_uart
    snd_seq_device          8781  4 snd_seq_dummy,snd_seq_oss,snd_seq,snd_rawmidi
    snd                    57157  11 snd_via82xx,snd_ac97_codec,snd_seq_oss,snd_seq,snd_pcm_oss,snd_mixer_oss,snd_pcm
    soundcore              10913  1 snd
    ne2k_pci               10657  0
    8390                   14149  1 ne2k_pci
    floppy                 65269  0
    dm_snapshot            17413  0
    dm_zero                 2113  0
    dm_mirror              26029  0
    ext3                  132553  2
    jbd                    86233  1 ext3
    dm_mod                 58101  6 dm_snapshot,dm_zero,dm_mirror

Any help would be apreciated...
Go to the top of the page
+Quote Post
Start new topic
post Feb 4 2009, 03:07 PM
Post #2

Whats this Lie-nix Thing?

Group: Members
Posts: 1
Joined: 13-April 08
Member No.: 13,421

Has it been long enough?

I still have the modem... still have linux... but I still don't have the modem working. I have changed distros probably 4 or 5 times now. Well in any case I don't guess anyone really wants to take a poke at an old dial up modem (external serial port...).

Thanks for the reads.
Go to the top of the page
+Quote Post

Posts in this topic

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:


RSS Lo-Fi Version Time is now: 15th July 2018 - 04:33 PM