Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )

Advanced DNS Management
New ZoneEdit. New Managment.


Sign Up Now
Reply to this topicStart new topic
> Routing, how the #@$%
post Mar 29 2003, 11:26 AM
Post #1

Whats this Lie-nix Thing?

Group: Members
Posts: 6
Joined: 29-March 03
Member No.: 600

I just got some wireless cards from best buy(belkin F5D6001 PCI)
(if you run linux DO NOT BUY THEESE CARDS!!!!) and I put one in a Mandrake 9 box,which I use to NAT my cable modem.
Iim gonna be verbose in case any of this might help someone else)

modprobe orinoco_pci
iwconfig mode Ad-hoc
iwconfig essid cha0snet
iwconfig channel 1
iwconfig rate 11Mb
ifconfig eth2

nano /etc/sysconfig/dhcp
(add eth2 to list of interfaces)
nano /etc/dhcp/dhcp.conf
(add subnet declaration etc...)
/etc/init.d/dhcp restart

put another card in win98 box boot it up it dhcp's

now i can see the smb shares of every box on the lan, however i can only use ones on the network and the linux box(
i also nat that connection so wireless98 box has internet access

now the weird part.
I load up a movie on wireless box it gets about 5 min in then wireless card craps out.nothing fixes it short of a reboot.
if i dont use it connection stays up indefinatly.
any activity at all and 5 min is the longest it lasts.

now the weirder part.
take the card out of linux box, put in xp box
works great WONT GO ABOVE 2 Mb/s

build another computer put on board vga(old 133)
put isa 3com 3c509 and wireless card in.
put knoppix cd in as that was only thing worked*
boots up i have it dhcp
make wireless card
now its working fine.
*(i left out installing 7!!!! different distro's and having weird 5 min problem
except knoppix from cd.if i installed if to hard drive it broke something.)

so now i need help routing.
mandrake 9
eth0 is and
eth1 is dhcped from comcast

eth0 is card)
eth1 dhcps from mandrake box

both boxes ipfilter NATting
so now wireless box has internet access can ping anything on the internet and and but not any other 192.168.0.n on my net.
linux box can ping but not
192.168.0.n computers can ping but not

i tried
route add -net netmask gw
on knoppix box and
route add -net netmask gw
on mandrake box
and that didnt work...

anyone know how i make it so can use windows file share on having to pass through and on the way??

or a better addressing plan that would work?

or any help at all would be greatly appreciated

Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:


RSS Lo-Fi Version Time is now: 18th March 2018 - 12:42 AM