Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> Really Need Assistance.., Difficulties in updating/installing
djcool
post Oct 27 2005, 08:51 AM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 4
Joined: 27-October 05
Member No.: 5,673



Hello there. I am a newbie when it comes to Linux. I have just installed SuSE 9.3 in my pc a few days back. However didn't have much time to snoop arnd. Today when i tried updating via YaST, i got this error msg
QUOTE
" pmdb: PANIC: fatal region error detected; run recovery
error: db4 error(-30978) from dbenv->close: DB_RUNRECOVERY: Fatal error, run database recovery "

Thats the same error message i get when i try to install anything at all even from the CD. Where did i go wrong.


--------------------
Distro: SuSE 9.3
System: Intel Pentium IV 2400Mhz Via Gigabyte 865PE
NVIDIA GeForce FX5200
512MB 333 MHz DDR SDRAM
17" Philips LCD Monitor
Go to the top of the page
 
+Quote Post
djcool
post Oct 27 2005, 10:09 AM
Post #2


Whats this Lie-nix Thing?
*

Group: Members
Posts: 4
Joined: 27-October 05
Member No.: 5,673



Sorry to the moderators for creating 3 of the messages. It showed error twice so i added post again and again. Before i knew it all actually went through and well the rest u know..... My sincere apologies..


--------------------
Distro: SuSE 9.3
System: Intel Pentium IV 2400Mhz Via Gigabyte 865PE
NVIDIA GeForce FX5200
512MB 333 MHz DDR SDRAM
17" Philips LCD Monitor
Go to the top of the page
 
+Quote Post
Jim
post Oct 27 2005, 11:17 AM
Post #3


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,280
Joined: 19-November 03
From: University of Minnesota- TC
Member No.: 1,828



I have never seen this error before. It looks like a hard drive failure but I am not sure. When does it show up? During post? If you could get the last couples lines before this error pops up that would help. Or if it doesn't come up during post could you please describe where it comes up?

Don't worry about the multiple posts, there is a glitch in the forums that is causing that. I am going to go delete them right now.


--------------------
--Jim Lester
jim@linuxhelp.net

Distro: Gentoo
System: AMD Athlon 3000+ XP 2.166 GHz
NVIDIA nForce2 IGP Chipset
1GB 333 MHz DDR SDRAM
NVIDIA nForce2 Dual Head 64 MB Graphics

Server Distro: CentOS
Go to the top of the page
 
+Quote Post
djcool
post Oct 28 2005, 12:57 AM
Post #4


Whats this Lie-nix Thing?
*

Group: Members
Posts: 4
Joined: 27-October 05
Member No.: 5,673



Well i actually i was patching the "Multimedia Option Pack 1" into my system. Halfway patching it would pop up an error message saying "Error installing Multimedia-Option-Patch-1. Skip this patch or abort" So when i try again, It will fail and the log goes like this
CODE
" RROR(InstTarget:E_RpmDB_subprocess_failed)
rpmdb: PANIC: Invalid argument
rpmdb: PANIC: fatal region error detected; run recovery
error: db4 error(-30978) from dbcursor->c_put: DB_RUNRECOVERY: Fatal error, run database recovery
error: error(-30978) storing record  into Requireversion
rpmdb: PANIC: fatal region error detected; run recovery
error: db4 error(-30978) from dbcursor->c_get: DB_RUNRECOVERY: Fatal error, run database recovery
error: error(-30978) getting "" records from Requireversion index
rpmdb: PANIC: fatal region error detected; run recovery "....................................


I get this error message whenever i install anything..


--------------------
Distro: SuSE 9.3
System: Intel Pentium IV 2400Mhz Via Gigabyte 865PE
NVIDIA GeForce FX5200
512MB 333 MHz DDR SDRAM
17" Philips LCD Monitor
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 22nd October 2017 - 07:51 PM