Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> Webdav And Hwpassw, Problem with WebDav and hwpassw
dawn
post Oct 23 2005, 11:25 AM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 1
Joined: 23-October 05
Member No.: 5,662



I've installed WebDav on my Debian Sarge Root-Server. Everythings seems to be working but when I try to connect (in IE with File->Open(Open as Web-Folder)) I can't login. When I don't set a password via hwpasswd I don't have any problems...

my httpd.conf:
CODE
<IfModule mod_dav.c>
   DAVLockDB   /var/lock/DAV/DAVLock
       <Directory /var/www/dav>
       DAV On
       <Limit PUT POST DELETE PROPFIND PROPPATCH MKCOL COPY MOVE LOCK UNLOCK>
               AuthName "WebDAV Access"
               AuthType basic
               AuthUserFile /etc/apache/htpasswd/davpasswd
               require user dav
       </Limit>
       </Directory>
</IfModule>


I generated the davpasswd with:
CODE
htpasswd -c /etc/apache/htpasswd/davpasswd dav


Then I logged in to my root server via ssh and tried my installation with litmus:
CODE
litmus http://217.20.***.***/dav dav [PASSWORT]
-> running `basic':
0. init.................. pass
1. begin................. pass
2. options............... pass
3. put_get............... pass
4. put_get_utf8_segment.. pass
5. mkcol_over_plain...... pass
6. delete................ pass
7. delete_null........... pass
8. mkcol................. pass
9. mkcol_again........... pass
10. delete_coll........... pass
11. mkcol_no_parent....... pass
12. mkcol_with_body....... pass
13. finish................ pass
<- summary for `basic': of 14 tests run: 14 passed, 0 failed. 100.0%
-> running `copymove':
0. init.................. pass
1. begin................. pass
2. copy_init............. pass
3. copy_simple........... pass
4. copy_overwrite........ pass
5. copy_cleanup.......... pass
6. copy_coll............. pass
7. move.................. pass
8. move_coll............. pass
9. move_cleanup.......... pass
10. finish................ pass
<- summary for `copymove': of 11 tests run: 11 passed, 0 failed. 100.0%
-> running `props':
0. init.................. pass
1. begin................. pass
2. propfind_invalid...... pass
3. propfind_invalid2..... pass
4. propfind_d0........... pass
5. propinit.............. pass
6. propset............... pass
7. propget............... pass
8. propmove.............. pass
9. propget............... pass
10. propdeletes........... pass
11. propget............... pass
12. propreplace........... pass
13. propget............... pass
14. propnullns............ pass
15. propget............... pass
16. prophighunicode....... pass
17. propget............... pass
18. propvalnspace......... pass
19. propwformed........... pass
20. propinit.............. pass
21. propmanyns............ pass
22. propget............... pass
23. propcleanup........... pass
24. finish................ pass
<- summary for `props': of 25 tests run: 25 passed, 0 failed. 100.0%
-> running `locks':
0. init.................. pass
1. begin................. pass
2. options............... pass
3. precond............... pass
4. init_locks............ pass
5. put................... pass
6. lock_excl............. pass
7. discover.............. pass
8. notowner_modify....... pass
9. notowner_lock......... pass
10. owner_modify.......... pass
11. notowner_modify....... pass
12. notowner_lock......... pass
13. copy.................. pass
14. cond_put.............. FAIL (PUT conditional on lock and etag failed: 412 Precondition Failed)
15. fail_cond_put......... FAIL (conditional PUT with invalid lock-token code got 400)
16. cond_put_with_not..... FAIL (PUT with conditional (Not <DAV:no-lock>) failed: 400 Bad Request)
17. cond_put_corrupt_token WARNING: PUT failed with 400 not 423
   ...................... pass (with 1 warning)
18. complex_cond_put...... FAIL (PUT with complex conditional failed: 400 Bad Request)
19. fail_complex_cond_put. FAIL (PUT with complex bogus conditional should fail with 412: 400 Bad Request)
20. unlock................ pass
21. lock_shared........... pass
22. notowner_modify....... pass
23. notowner_lock......... pass
24. owner_modify.......... pass
25. double_sharedlock..... pass
26. notowner_modify....... pass
27. notowner_lock......... pass
28. unlock................ pass
29. finish................ pass
<- summary for `locks': of 30 tests run: 25 passed, 5 failed. 83.3%
-> 1 warning was issued.
See debug.log for network/debug traces.


Rights:
CODE
xr-xr-x  3 www-data www-data 4096 2005-10-22 18:00 dav


CODE
-rw-r--r--  1 www-data www-data    18 2005-10-22 17:10 davpasswd


I don't know whats the problem, but I've searched hours for a solution... There must be a little fault...

It would be nice if anybody can help me!

Thanks and best regards anyway,
Dawn
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 21st October 2017 - 09:55 PM