Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> Ypbind, ypbind failing upon startup
brock
post Oct 5 2005, 11:27 AM
Post #1


Grub-er
**

Group: Members
Posts: 29
Joined: 15-July 05
Member No.: 5,271



Hi,

Just done a fresh install of SuSe 9.2 and upon reboot/startup it spends ages trying to start ypbind and eventually fails and then continues to boot - /var/log reports the following: ypbind[3078]: broadcast: RPC: Timed out.

It is setup to authenticate using our NIS server and domain. I tried doing it manaully and it also times out. What I can't figure out is at the logon window it seems to have grabbed all of the users in the NIS domain to enable them to logon.

I new to Linux so don't fully understand it yet so any help welcome smile.gif

Could the lenght of the netwrok cable be a factor as this server is networked across a road to the other network, at a guess 120ft.

It has worked in the past though with the previous installation.
Go to the top of the page
 
+Quote Post
DS2K3
post Oct 6 2005, 11:45 AM
Post #2


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,284
Joined: 14-November 04
From: Southampton, Hampshire
Member No.: 4,165



Have you tried setting the IP address of the NIS server? The boradcast could be filtered by firewalls or routers (check you dont have iptables enabled).

D


--------------------
Fixed your problem? Let us know!
richard@linuxhelp.net

www.Gathr.co.uk Online Event Management
Go to the top of the page
 
+Quote Post
brock
post Oct 7 2005, 05:09 AM
Post #3


Grub-er
**

Group: Members
Posts: 29
Joined: 15-July 05
Member No.: 5,271



I have set the IP number to the NIS server, both the NIS server and the server I have the problem with have no firewalls enabled. I reluctant to use the 'broadcast' option , seems a shotgun approach to solving this problem.

I did a searched yesterday and found a reference to a bug/glitch in ypbind for Novell SUSE 9.3 but I cannot find the link now sad.gif

It was along the line that it was 'forking process' and it to do with timing.
Go to the top of the page
 
+Quote Post
brock
post Oct 19 2005, 05:48 AM
Post #4


Grub-er
**

Group: Members
Posts: 29
Joined: 15-July 05
Member No.: 5,271



I took the easy route out and just did a total re-install and it works fine now. I cannot find a DVD (I can download 6 iso CD images) iso imageof SUSE 9.3 server, only 9.3 pro seems to be on DVD. Oh well, its up and running now, ypbind is happy, got samba and swat configured and working great. One thing I can't figure out is how to remove old NIS users from the database - there are a whole load of non-existent users at the logon prompt.
Go to the top of the page
 
+Quote Post
DS2K3
post Oct 19 2005, 09:00 AM
Post #5


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,284
Joined: 14-November 04
From: Southampton, Hampshire
Member No.: 4,165



Try and find the makefile for the database. It's normally in /var/yp/ or similar (just run "make" as root)

D


--------------------
Fixed your problem? Let us know!
richard@linuxhelp.net

www.Gathr.co.uk Online Event Management
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 15th December 2017 - 02:59 PM