Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )

Advanced DNS Management
New ZoneEdit. New Managment.


Sign Up Now
Reply to this topicStart new topic
> Configure And --prefix (gtk+)
post Sep 30 2005, 10:08 AM
Post #1

Whats this Lie-nix Thing?

Group: Members
Posts: 1
Joined: 30-September 05
Member No.: 5,574


In short, my question is: How do I install software into a non-standard "--prefix" directory and have it use libraries that are also in that non-standard directory? And more verbosely:

I wanted to do some testing and source-watching with more recent gnome software. I downloaded the cairo-1.10, glib-2.8.2, pango-1.10.0 and gtk+-2.8.4 sources. cairo, glib and pango installed nicely into a testing-directory. Now, when it comes to gtk+, I'm running into problems.

First, I set these environment variables to account for the non-standard install destination:

export LD_LIBRARY_PATH="/local-testing/lib"
export LDFLAGS="-L/local-testing/lib"
export PKG_CONFIG_PATH="/local-testing/lib/pkgconfig/"
export CPPFLAGS="-I/local-testing/include"

And I then ran configure in the gtk+ source dir:

./configure --prefix=/local-testing

Which ran through correctly. Then I started make. This failed:

gcc -g -O2 -Wall -o .libs/gtk-query-immodules-2.0 queryimmodules.o  -L/home/svara/local-testing/lib ./.libs/ /home/svara/archive-local/gtk+-2.8.4/gdk/.libs/ /usr/lib/ ../gdk-pixbuf/.libs/ ../gdk/.libs/ -lXrandr -lXinerama /home/svara/local-testing/lib/ /home/svara/local-testing/lib/ /home/svara/local-testing/lib/ /usr/lib/ /usr/lib/ /usr/lib/ /home/svara/local-testing/lib/ -lpng12 /usr/lib/ /usr/lib/ -lz /usr/lib/ -lXcursor -lXrender -lXext -lXfixes -lX11 /home/svara/archive-local/gtk+-2.8.4/gdk-pixbuf/.libs/ /home/svara/local-testing/lib/ -ldl /home/svara/local-testing/lib/ /home/svara/local-testing/lib/ -lm -Wl,--rpath -Wl,/home/svara/local-testing/lib
/usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.6/../../../../i686-pc-linux-gnu/bin/ld: warning:, needed by /home/svara/local-testing/lib/, may conflict with
./.libs/ undefined reference to `g_file_set_contents'
./.libs/ undefined reference to `g_utf8_collate_key_for_filename'
./.libs/ undefined reference to `g_get_host_name'
./.libs/ undefined reference to `g_mapped_file_free'
./.libs/ undefined reference to `g_mapped_file_new'
./.libs/ undefined reference to `g_mapped_file_get_contents'
collect2: ld returned 1 exit status
make[4]: *** [gtk-query-immodules-2.0] Error 1
make[4]: Leaving directory `/home/svara/archive-local/gtk+-2.8.4/gtk'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/home/svara/archive-local/gtk+-2.8.4/gtk'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/home/svara/archive-local/gtk+-2.8.4/gtk'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/svara/archive-local/gtk+-2.8.4'
make: *** [all] Error 2

After some testing, it became obvious that make was actually using the older glib-libraries (2.6.5) installed by portage. Those "undefined symbols" simply don't exist in the old glib version, but are present in 2.8.2 which is installed into /local-testing/lib. To confirm this, I renamed the 2.6.5 glib-libraries in /usr/lib such as to break everything that depends on them and ran make again. It complained about not being able to find glib in /usr/lib (which I <i>don't want it to use</i>).

So.. What did I miss? Is there some environment variable I forgot to export to tell make to not use the stuff in /usr/lib? Some configure option?

Thanks in advance for any help,
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:


RSS Lo-Fi Version Time is now: 19th March 2018 - 03:48 AM