Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> Ftp Failure On Linux...., Networking issue, mainly
Dunhill
post Jul 20 2005, 02:15 AM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 22
Joined: 6-July 05
Member No.: 5,230



Hi,
I am a little bit new in Linux, if dun say completely new.... currently I encountered some problem in Linux network.


For RH9, i can use the ftp in windows. but for RHE3:
Windows can not access this folder, Make sure you typed file name correctly and that you have permission to access the folder.
Details,
220 RHE3 FTP server (version 5.60) ready,
530 Must perform authentication before identifying USER.

For RHE4, warning/error message is the same. what is wrong? I check the service in RHE3 and RHE4, in System Settings--Server Settings--Service, I check the server gssftp but i can neither start or stop this service. what should I do? sad.gif



Please help me on this issue. Btw, for a newbie like me, how should I start to learn? read books? if so any recommendatioins?

Thanks!
Go to the top of the page
 
+Quote Post
Dunhill
post Jul 20 2005, 07:41 PM
Post #2


Whats this Lie-nix Thing?
*

Group: Members
Posts: 22
Joined: 6-July 05
Member No.: 5,230



Hi... Can any1 help? blink.gif sad.gif blink.gif sad.gif
Go to the top of the page
 
+Quote Post
Dunhill
post Jul 26 2005, 12:00 AM
Post #3


Whats this Lie-nix Thing?
*

Group: Members
Posts: 22
Joined: 6-July 05
Member No.: 5,230



Hi, how to perform authentication in linux? I try a few settings and rebooted but seems nothing has changed.
Go to the top of the page
 
+Quote Post
Termina
post Jul 27 2005, 03:16 AM
Post #4


RMS is my Hero
******

Group: Support Specialist
Posts: 862
Joined: 18-February 04
From: Wisconsin
Member No.: 2,404



Please make sure of the following:

* User you are trying to log in with has a valid system account
* User owns their home directory (and that it is created!). chown -R user /home/user && chmod -R 755 /home/user
* User's shell is set to /bin/bash (usermod -s /bin/bash user)
* If you are using IE or Windows Explorer instead of an FTP client, please use this syntax:

ftp://user:pass@servername.com

It looks like you forgot to supply a password. Otherwise, one of the other three above will probably help you.


--------------------
*Points finger at the author above him* They're a witch! Burn them!
---
Vist my website!
Join me in IRC! Server: st0rage.org Channel: #UnhandledExceptions
Go to the top of the page
 
+Quote Post
Dunhill
post Jul 27 2005, 07:09 PM
Post #5


Whats this Lie-nix Thing?
*

Group: Members
Posts: 22
Joined: 6-July 05
Member No.: 5,230



Thanks, will try it out!
Go to the top of the page
 
+Quote Post
Dunhill
post Jul 27 2005, 08:08 PM
Post #6


Whats this Lie-nix Thing?
*

Group: Members
Posts: 22
Joined: 6-July 05
Member No.: 5,230



Dear Termina,

I have a valid user account (work) at the Linux machine, it has a full-controlled 777 home directory /home/work, and its shell is /bin/bash. The setting is so similiar to Red Hat 9 in which i did not encounter any problem to use ftp to user work's directory from my PC.

Originally I use the Windows network place, new entry is like this ftp://work:workpassword@xx.xxx.xx.xx/

After see your post, I tried ftp://work:workpassword@xx.xxx.xx.xx in a browser, it failed. Warning is like this:
Windows can not access the folder, Make sure you typed the file name correctly and you have the permission to access that file.
Details: connection with the server has been reset.

What is the problem of this?
Go to the top of the page
 
+Quote Post
Termina
post Jul 27 2005, 11:50 PM
Post #7


RMS is my Hero
******

Group: Support Specialist
Posts: 862
Joined: 18-February 04
From: Wisconsin
Member No.: 2,404



Very strange. Is this in your LAN?

On the server, please try 'iptabels -F', and try again.

You're able to log into FTP locally, right?

Are you using the same FTP server on both machines?


--------------------
*Points finger at the author above him* They're a witch! Burn them!
---
Vist my website!
Join me in IRC! Server: st0rage.org Channel: #UnhandledExceptions
Go to the top of the page
 
+Quote Post
Dunhill
post Jul 29 2005, 02:44 AM
Post #8


Whats this Lie-nix Thing?
*

Group: Members
Posts: 22
Joined: 6-July 05
Member No.: 5,230



Of course in the LAN. In our LAN, i like to let these three PCs to communication with each other:
1 Windows XP: A
1 RH 9:B user (dunhill), ftp folder (dunhill)
1 RHE4:C user (dunhill), ftp folder (dunhill)

From machine A, go to "My network Place" , add connection as " ftp://dunhill:mypassword@xxx.xx.xx.xxx" then I can go to B, but similarly i can not go to C, the warning is as above i posted...

the command iptables -F is for what purpose?
Go to the top of the page
 
+Quote Post
Termina
post Jul 29 2005, 10:12 AM
Post #9


RMS is my Hero
******

Group: Support Specialist
Posts: 862
Joined: 18-February 04
From: Wisconsin
Member No.: 2,404



You could just 'man iptables' to find out. wink.gif

Sorry, I should have mentioned. It flushes out the iptables rules (it shoudl basically disable the firewall, and you won't need it if you're in a LAN).


--------------------
*Points finger at the author above him* They're a witch! Burn them!
---
Vist my website!
Join me in IRC! Server: st0rage.org Channel: #UnhandledExceptions
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 13th December 2017 - 07:32 PM