Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> Openssh On Mandrake 10.0, how to configure / install
perrin457
post Jul 12 2005, 01:41 AM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 5
Joined: 12-July 05
From: Eastern Suburbs, Victoria, Australia
Member No.: 5,261



i am 'attempting' to install and configure OpenSSH on my mandrake machine, so i can control it remotely through Putty.
I have installed the RPM's of
openssh-3.6.1p2-12mdk.i586.rpm
openssh-server-3.6.1p2-12mdk.i586.rpm
openssh-clients-3.6.1p2-12mdk.i586.rpm

and i can use the ssh command in terminal, but i dont know how to set it up to accept remote connections?
something about a hosts.allow and hosts.deny file?
how do i use these files?

Thanks

Perrin
Go to the top of the page
 
+Quote Post
DS2K3
post Jul 12 2005, 05:18 AM
Post #2


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,284
Joined: 14-November 04
From: Southampton, Hampshire
Member No.: 4,165



EITHER use hosts.allow or hosts.deny

Its more secure to use hosts.allow, and if you know the IP of your client PC then use it. Just put the IP address of the machine you want to connect from into it.

Otherewise, you could use hosts.deny and just put addresses into it that want to deny. (Or leave it blank)

Just remember to delete or rename the other one.

D


--------------------
Fixed your problem? Let us know!
richard@linuxhelp.net

www.Gathr.co.uk Online Event Management
Go to the top of the page
 
+Quote Post
perrin457
post Jul 12 2005, 05:41 AM
Post #3


Whats this Lie-nix Thing?
*

Group: Members
Posts: 5
Joined: 12-July 05
From: Eastern Suburbs, Victoria, Australia
Member No.: 5,261



i have added
sshd:ALL
into my hosts.allow file

i want to be able to access my server from any location on the internet, so i think this is the only way to do it.

how do i make a password for openSSH?
i can connect to it now, and it asks for login: and password:
and its not my root password..

any ideas?
Go to the top of the page
 
+Quote Post
michaelk
post Jul 12 2005, 05:49 AM
Post #4


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,797
Joined: 23-January 03
Member No.: 360



Have you tried a regular user? I would assume that root login would be disabled by default for security reasons. Once logged in you can use su for root access.

Look in the sshd config file for the setting permitrootlogin. You can change it from no to yes but as I mentioned before it is a bad idea.
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 22nd October 2017 - 09:22 PM