Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> Newbie Kernel Compilation Woes, I think I seriously messed something up.
zue
post Jul 6 2005, 10:22 PM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 2
Joined: 6-July 05
Member No.: 5,229



Hi. I've been using linux for all of 3 weeks or so now, so I figure that qualifies me as a newbie. My distro is ubuntu, I don't know if that makes a difference with this particular problem.

So here's my immediate problem. A few days after I first installed ubuntu I decided to update the kernel (using the very helpful HOWTO I found on the ubuntu forum), because I needed the 2.6.12 kernel to fix a system clock problem I was having (it was going 2x too fast). My first couple compiles wouldn't boot at all (some kind of VFS kernel panic), so I got someone else's .config file, modified it a bit, and used it to compile a kernel that would boot. It worked, but I noticed an error on startup that had something to do with IO-APIC and NMI Watchdog. With the help of some people more knowledgeable than myself, we narrowed this down to APIC support not being turned on when I compiled my kernel. I was told to look for this in "Processor Type and Features" > "Local APIC support on uniprocessors" (CONFIG_X86_UP_APIC). It wasn't there. I decided that I must've done something really weird so I started clean with the other person's .config file again. That's when I noticed that when I ran make xconfig I got like fifty messages like this:

CODE
.config:104: trying to assign nonexistent symbol X86_POPAD_OK
.config:106: trying to assign nonexistent symbol X86_INTEL_USERCOPY
.config:107: trying to assign nonexistent symbol X86_USE_PPRO_CHECKSUM
.config:112: trying to assign nonexistent symbol X86_UP_APIC
.config:113: trying to assign nonexistent symbol X86_UP_IOAPIC
.config:118: trying to assign nonexistent symbol X86_MCE_NONFATAL



They all look like that but with different numbers and nonexistent symbols. This might have been happening right from the start (I may not have been paying attention to the output whem I ran make xconfig before). Anyway, this explains why I don't have a local APIC support option to turn on.

The next thing I tried is starting over with the next kernel revision (first one was 2.6.12.1 and now I have 2.6.12.2). Being a dumbass I thought whatever I broke might be overwritten and all would be good. Not so. Now not only do I get all that nonexistent symbol stuff I had before, but I also get this error when I run make xconfig:


CODE
/usr/bin/ld: cannot find -lqt
collect2: ld returned 1 exit status
make[1]: *** [scripts/kconfig/qconf] Error 1
make: *** [xconfig] Error 2




...so I'm stuck with menuconfig. Can somebody help me fix this mess I made? Please? Or am I better off just reinstalling ubuntu?

Thanks in advance,
Zue
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 18th October 2017 - 06:21 AM