Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )

Advanced DNS Management
New ZoneEdit. New Managment.


Sign Up Now
Reply to this topicStart new topic
> Nfs, Errors with rpcinfo -p
post Jul 5 2005, 12:15 PM
Post #1

Whats this Lie-nix Thing?

Group: Members
Posts: 7
Joined: 24-June 05
Member No.: 5,173

Iím at the step where I need to verify portmap is working OK on the box I want to share.

IN the process of preparing a FC3 Linux box to share a directory out.

I get this error when I run Rpcinfo Ėp:
can't contact portmapper: RPC: Remote system error- Connection denied

Researching articles on the web, I found out this could be because of some errors in hosts.allow/deny or my exports file.
I believe my syntax is correct & when I change it, I believe it exports OK, as I donít get any errors (or anything else ) when I do this command:
Exportfs Ėr

When I run nfs restart all daemons start except portmap.
For that I get the following error:
RPC: failed to contact portmap (errno-5)

Then I tried exportfs Ėvar
It seemed to work as it said:
ďexporting *:/home/mark

Then running nfs restart does work
But I still get that error when running rpcinfo Ėp

And a portmapper failure error when running
Showmount -e

Iíve tried putting the FQH name & then the IP address for my share server in the exports file, that didnít work so I took it out.

At one time I also changed my hosts.allow file to ALL: ALL

Iíve found out (correctly I hope) that even though I want portmap I need to have an entry in the hosts.deny file such as: portmap: ALL
But Iíve also tried it without this entry in here & it the hosts.allow file.

The box Iíd like to share-out is
The box Iíd like to connect to it is

Iíve included my hosts & exportfs files below.
Any information would be helpful.
I donít know if this has anything to do with it, but my NIC doesnít retain itís values (ip/mask) info even though I put it in the /etc/sysconfig/network-scripts/ifcfg-eth0 file. But I do get IP by manually using the ifconfig command.
So I included that as well.

Thank you,


#Exports file
/home/mark *(no_root_squash)

# hosts.allow This file describes the names of the hosts which are
# allowed to use the local INET services, as decided
# by the '/usr/sbin/tcpd' server.

# hosts.deny This file describes the names of the hosts which are
# *not* allowed to use the local INET services, as decided
# by the '/usr/sbin/tcpd' server.
# The portmap line is redundant, but it is left to remind you that
# the new secure portmap uses hosts.deny and hosts.allow. In articular
# you should know that NFS uses portmap!
portmap: ALL

#This should be autoconfiguring my card, but it's not!
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:


RSS Lo-Fi Version Time is now: 24th March 2018 - 09:13 AM