Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> Conexant V90 56k Modem, Not working
richessence
post Jun 28 2005, 02:03 PM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 7
Joined: 24-June 05
Member No.: 5,173



I installed & tried initializing this modem in X but it gave me:
“failed to activate with error 6”

The modem does not include any helpful info about the chipset in the documentation.
So from a combo of books & online info I did the following:


This is the output of my lspci-v
01:08.0 comm controller: conexant HSF 56k HSFi modem (rev 01)
sybsystem: zoom telephonics inc: unknown device 8d88
flags: bus master, medium devsel, latency 64, IRQ 11
memory at 40000000 (32-bin, non-prefetchable) [size=64k]
I/O ports at 14c0 [size=8]
Capabilities: [40] power management version 2

Kudzu has added this to hwconf
-
class: MODEM
bus: PCI
detached: 0
driver: unknown
desc: "Conexant HSF 56k HSFi Modem"
vendorId: 14f1
deviceId: 2f00
subVendorId: 141b
subDeviceId: 8d88
pciType: 1
pcidom: 0
pcibus: 1
pcidev: 8
pcifn: 0
-

Then I did the following & got no errors
Cd /dev
Test –c ttyS3
./MAKEDEV ttyS3
chmod 666 /dev/ttyS3
setserial /dev/ttyS3 uart 16550 port 0x2460 irq 11
ln –sf /dev/ttyS3 /dev/modem

NOTE: I got the port & irq addresses as a result from cat /proc/pci
They were the first port & irq listed.

But then when I run minicom, it says it’s initializing but then does not give me the “ok” prompt.
Also, on the shell, I get no “ok” when I do an echo “atdt” > /dev/ttyS3

So, I’m wondering if the output of the lspci & contents of hwconf indicate that this modem has it’s own controller & should be working.

If linux is recognizing this & if the modem does have it’s own controller, the only thing I can see wrong is the “unknown device 8d88” in the lspci message & the “driver: unknown” in the hwconf file.

I’m wondering maybe based on the info I have listed here the modem is recognized & should work, & if that’s the case what am I not doing/doing wrong?

Or, if I need the driver, how can I:
1. Locate a proper driver on the Linmodem site when there are several pertaining to conexant?
2. How do I install the driver & associate it with /dev/ttyS3?
3. If it’s recognizing the controller/chipset can I use a generic driver, & how?

Thank you for your input,

Mark
Go to the top of the page
 
+Quote Post
richessence
post Jun 28 2005, 02:05 PM
Post #2


Whats this Lie-nix Thing?
*

Group: Members
Posts: 7
Joined: 24-June 05
Member No.: 5,173



PS I'm using Core 3 kernel 2.6.12
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 21st October 2017 - 12:00 AM