Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> Defaulting To Video1, How to change default video card
mrfearless47
post Jun 25 2005, 02:57 PM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 2
Joined: 25-June 05
Member No.: 5,177



I've bumped into a seemingly intractable problem. I have a garden variety Dell 2350 that dual boots Windows XP and Fedora. About a month ago, the onboard video controller (an Intel 845 chipset) started acting up (this, apparently is not uncommon with this controller). I did not want to replace the motherboard so I installed an ATI Radeon 7000 PCI video card, which works fine in Windows XP. To get this to run in Windows XP, I did have to go into the BIOS and change the video controller from "onboard" to "AUTO". Once I did that, Windows XP worked fine. However, and as you might suspect, when I went to boot Fedora Core (3 at the time), the boot process would stop with a segmentation fault immediately following the attempt to probe for video hardware (of course, the installation had been done originally with the onboard controller). Since I didn't have much that I cared about on the Linux install at that point, I decided to blow away the FC 3 installation and install FC4 when it came out. I started on this project about 4 days ago. At first I couldn't install anything because Anaconda would segfault or core dump depending on whether I started in graphical mode or in text mode. Finally, I discovered that I could use boot: linux install noprobe and this would get the installer moving. In text mode, the installer discovered the ATI Radeon card and everything installed without a hitch. However, when I rebooted, the system could never get beyond the initial stages because -- as I later discovered -- it recorded the ATI Radeon as video0 in the xorg.conf file.

At this point I'm stuck. I NEED for Linux to accept the fact that I WANT to boot with video1 as the ONLY video card. I have no idea how to edit xorg.conf to convince it that there is NO video0. (There also is no jumper on the Dell motherboard to completely shut down the onboard controller; only a BIOS toggle that effectively tells it to use whichever video has a monitor attached, or dual monitors if two video cards and two monitors are attached).

Is there a software solution to this problem or is this otherwise good machine consigned to be a Windows only box?

Thanks. sad.gif
Go to the top of the page
 
+Quote Post
Corey
post Jun 25 2005, 03:06 PM
Post #2


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 1,254
Joined: 21-September 02
From: St John's, Newfoundland, Canada
Member No.: 3



As far as i know, /dev/video0 and /dev/video1 are not related to your video card. They usually refer to Video For Linux with stuff like Webcams, tv tuners, etc.

In your BIOS, you said you set th evideo controller to "AUTO", is there a setting for AGP or PCI? If so, you should change it to this setting. I have an nforce motherboard, and when i added a geforce4 card in to replace the onboard geforce2, all i did was go into the BIOS and changed the video from "onboard" to "AGP".

If you set it to AGP (if there is that setting), then there will be no question as to which vid it will use.


--------------------
Corey Quilliam
(former) Linuxhelp.ca Administrator
cquilliam-AT-gmail-dot-com

Want to help out Linuxhelp.net? Check out our Linuxhelp Wiki and see if there are some articles you would like to submit!!

--
Ubuntu 8.04 64-bit - Work Laptop (HP-Compaq NC6400 Core2)
Kubuntu 8.04 64-bit - Desktop (HP m8120n QuadCore)
Ubuntu 6.04 - Server (I'm not upgrading this baby until support runs out in 2012) (Some old POS dell)
Go to the top of the page
 
+Quote Post
mrfearless47
post Jun 25 2005, 05:46 PM
Post #3


Whats this Lie-nix Thing?
*

Group: Members
Posts: 2
Joined: 25-June 05
Member No.: 5,177



In xorg.conf there is a specific reference to video0 and video1 that are associated directly with the installed video card in the machine. In fact, when you inspect xorg.conf, the section where video0 is defined includes the precise brand and name of the card (ATI Radeon 7000 or intel845). It is hard for me to see how this doesn't relate to the video board installed in the machine. AFAIK, we're not talking about /dev/video0. As for BIOS configuration, the Dell 2350 makes no distinction between PCI and AGP video. It is either onboard (AGP) or AUTO. There is no way to disable AGP polling, nor is there any way to disable the onboard video at all. The BIOS is about as basic as you can find. I've combed it completely and there is a single toggle for video, which is under "Peripheral Device Configuration". There are four entries, relating to sound, USB, video, and printing. Each have several options, but under video it is either "onboard" or "AUTO".

I wish it were as simple as you explain. It would save a lot of grief. Right now, I'm simply hitting my head with a bigger hammer trying to solve what may be unsolveable.
Go to the top of the page
 
+Quote Post
therexxman
post Jul 13 2005, 08:14 PM
Post #4


Whats this Lie-nix Thing?
*

Group: Members
Posts: 1
Joined: 13-July 05
Member No.: 5,268



I had/am having the same problem; only difference is I am trying to use an nVidia card. My hopefully, temporary solution was to remove the nVidia card, and FC4 installs fine.
If this problem has been resolved, I would appreciate knowing how.

Thanks.
Go to the top of the page
 
+Quote Post
harry_whodunnit
post Jul 30 2005, 03:24 AM
Post #5


Whats this Lie-nix Thing?
*

Group: Members
Posts: 2
Joined: 30-July 05
Member No.: 5,343



I have that problem too. A Via Technologies ms6368 motherboard, with a PCI GeForce replacing the onboard Trident CyberBlade.

Setting the BIOS to check for PCI video devices causes FC3 to stall at detecting hardware.
Go to the top of the page
 
+Quote Post
harry_whodunnit
post Jul 31 2005, 02:38 PM
Post #6


Whats this Lie-nix Thing?
*

Group: Members
Posts: 2
Joined: 30-July 05
Member No.: 5,343



Possible solution: Redhat bug report

Looks like this was a known issue, and a fix for it was included in the FC3 kernal update released on 15 July. Installing kernel-2.6.12-1.1372_FC3 fixed the problem for me.

Remember to chmod the kernal to make it writeable, and boot from the updated kernal afterwards -- it'll save you the two hours of head-scratching I did.
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 19th October 2017 - 06:21 PM