Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> Tried 3 Versions Still No Joy!, Can't get displayworking
NI_Sam
post Jun 15 2005, 03:20 PM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 3
Joined: 15-June 05
Member No.: 5,123



Hi,

I'm a newbie to installing Linux, I've used it and Unix occasionally in work but have never installed it before.

Anyway, after spending the time downloading and installing 3 different versions of linux (fedora 3, fedora 4, and Ubuntu) all 64 bit versions and being unable to see so much as a recognisable screen due to what appears to be graphics related problems I'm nearly ready to give the idea up and return permanently to Mr Gates biggrin.gif

My system is as follows (Shuttle XPC SN25P) :

AMD 64 Athlon
PCI Express Nvidia GeForce 6600GT graphics card
NVIDIA nForce 4 chipset
.....

After every install completes (the graphical install wouldn't work for Fedora) I'm met with a completly garbled screen. sad.gif mad.gif

I've tried downloading the following driver from nVidia but the installation produces various errors and many complaints and falls over.

Can anyone help with any suggestions to resolve this?

Thanks in advace,

Sam
Go to the top of the page
 
+Quote Post
Corey
post Jun 15 2005, 07:30 PM
Post #2


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 1,254
Joined: 21-September 02
From: St John's, Newfoundland, Canada
Member No.: 3



Well, under Ubuntu, you should be able to install the drivers directly from them and not use the one's from nvidia's site. I'm not sure if this is your problem or not.

When you boot into Ubuntu and get to the console, login and do something like:

apt-cache search nvidia

It should bring up a bunch of matches. Check what kernel you're running with:

uname -r

Then install the restricted-modules package that appears in the search, this includes the nvidia driver as far as i know. After this, edit your /etc/X11/xorg.conf file and change in the device section "nv" to "nvidia" then try to start your X server with "startx"

Out of curiosty, what monitor do you have? I've had lots of problems with more recent versions of XFree86 and Xorg on certain monitors i've tried.


--------------------
Corey Quilliam
(former) Linuxhelp.ca Administrator
cquilliam-AT-gmail-dot-com

Want to help out Linuxhelp.net? Check out our Linuxhelp Wiki and see if there are some articles you would like to submit!!

--
Ubuntu 8.04 64-bit - Work Laptop (HP-Compaq NC6400 Core2)
Kubuntu 8.04 64-bit - Desktop (HP m8120n QuadCore)
Ubuntu 6.04 - Server (I'm not upgrading this baby until support runs out in 2012) (Some old POS dell)
Go to the top of the page
 
+Quote Post
homerglemkin
post Jun 17 2005, 11:23 AM
Post #3


Whats this Lie-nix Thing?
*

Group: Members
Posts: 5
Joined: 15-June 05
Member No.: 5,121



In Ubuntu I had to fix the /etc/X11/xorg.conf file and take out the vertical and horizontal refresh
You should back this up before messing with it. sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf_backup
Section "Monitor"
Identifier "Generic Monitor"
Option "DPMS"
EndSection

After doing this it worked fine.

For the nvidia driver I followed th unofficial Ubuntu guide
http://ubuntuguide.org/
sudo apt-get install nvidia-glx
sudo apt-get install nvidia-settings
sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf_backup
sudo nvidia-glx-config enable
sudo gedit /usr/share/applications/NVIDIA-Settings.desktop
and enter the following:
[Desktop Entry]
Name=NVIDIA Settings
Comment=NVIDIA Settings
Exec=nvidia-settings
Icon=
Terminal=false
Type=Application
Categories=Application;System;

The guide works great for new installs.
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 19th October 2017 - 03:15 PM