Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> Change Open Directory Into A Closed One
rogier1983
post Jun 12 2005, 11:34 AM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 2
Joined: 12-June 05
Member No.: 5,114



Question form a Linux nOOb:

I just started my http server on linux Suze 9.0 professional, and it works fine, accept for one little thing. Viewers from the site can navigate inside de directory ( I guess you could call it a open directory). But I want to restrict viewers, so that they can only open the files of which I gave the pathway.

For example http://65.234.2.1:7772/~peter/ they can't see anything,

but when the go to http://65.234.2.1:7772/~peter/scary.avi they can open the file

I hope somebody understands what I mean, I know it's a bit cryptic, but can someone help me?

greetzzz y'all
Go to the top of the page
 
+Quote Post
Termina
post Jun 12 2005, 10:54 PM
Post #2


RMS is my Hero
******

Group: Support Specialist
Posts: 862
Joined: 18-February 04
From: Wisconsin
Member No.: 2,404



I don't quite understand you, but perhaps one of these will help:

1) Put an index.html file in the directory you don't want people to see the contents of
2) .htaccess/.htpasswd ( http://linuxreviews.org/webdesign/htaccess/ )


--------------------
*Points finger at the author above him* They're a witch! Burn them!
---
Vist my website!
Join me in IRC! Server: st0rage.org Channel: #UnhandledExceptions
Go to the top of the page
 
+Quote Post
rogier1983
post Jun 13 2005, 03:54 AM
Post #3


Whats this Lie-nix Thing?
*

Group: Members
Posts: 2
Joined: 12-June 05
Member No.: 5,114



Thank you very much, I put a index.html in the public_html ; Problem fixed.....

biggrin.gif Thanks a happy nOOb
Go to the top of the page
 
+Quote Post
DS2K3
post Jun 13 2005, 08:56 AM
Post #4


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,284
Joined: 14-November 04
From: Southampton, Hampshire
Member No.: 4,165



You could also turn off "directory indexing" in your httpd.conf file, or by setting it using an .htaccess file (try googling, since i'm not 100% on what the option is called).

D


--------------------
Fixed your problem? Let us know!
richard@linuxhelp.net

www.Gathr.co.uk Online Event Management
Go to the top of the page
 
+Quote Post
Termina
post Jun 13 2005, 11:36 PM
Post #5


RMS is my Hero
******

Group: Support Specialist
Posts: 862
Joined: 18-February 04
From: Wisconsin
Member No.: 2,404



QUOTE (DS2K3 @ Jun 13 2005, 08:56 AM)
You could also turn off "directory indexing" in your httpd.conf file, or by setting it using an .htaccess file (try googling, since i'm not 100% on what the option is called).

D

I mentioned .htaccess above. wink.gif


--------------------
*Points finger at the author above him* They're a witch! Burn them!
---
Vist my website!
Join me in IRC! Server: st0rage.org Channel: #UnhandledExceptions
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 23rd October 2017 - 06:42 AM