Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> Slow Kde And Gnome, Other window managers work fine...
ktstone
post May 30 2005, 09:30 PM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 6
Joined: 21-May 05
Member No.: 5,019



This is getting to be very frustrating...

When I first installed, KDE worked great. I don't remember making any significant changes to anything before this happened.

All of a sudden, it now takes between 7 and 10 full minutes after login before KDE is ready to use. The same goes for gnome. Enlightenment, fluxbox, and fvwm all start immediately but I don't want to use those. After KDE is finally up and running, it takes another few minutes for any KDE specific applications to start. Konqueror and kget are two examples. If I close one of these applications and start them again later, it still takes several minutes for them to be up and running again.

Other applications start quickly as expected. Firefox, gaim, x-chat, gimp all work fine.

I don't know where to start with troubleshooting this problem, does anyone have any ideas? Let me know if I need to provide any more information.

Thanks-
Go to the top of the page
 
+Quote Post
Corey
post May 31 2005, 05:21 AM
Post #2


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 1,254
Joined: 21-September 02
From: St John's, Newfoundland, Canada
Member No.: 3



This could happen for a number of reasons, I know with KDE, this can be caused by services not starting and having to wait for them to timeout.

To test this out, try these things. First off, lets just do a quick check to see if it's a configuration problem. I will assume that your computer starts with a login manager like KDM or GDM, if so, then shut this down. You can do this by pressing Ctrl+Alt+F1 from your login screen, and log in as root, and stop the service (usually with '/etc/init.d/gdm stop' or whatnot). This should keep you in the console. Log out from root and log in as your normal user. Now, move your kde configuration directory:

QUOTE
mv ~/.kde ~/.kde-backup


You may have some symlinks pointing to ~/.kde , but don't worry about that. after this, go ahead and type "startx" and see if the problem persists. Either way, move on to the next step.

If KDE started fine, then you have a configuration error somewhere, where is hard to tell. If you dont' have much in the way of customization of your Desktop, you can just leave this as is and that's it. If you don't want to wipe out your settings, or if the previous step did nothing, then re-establish your settings:

QUOTE
mv ~/.kde-backup ~/.kde


And from the console screen, type startx. now, while KDE is loading (or Gnome), press Ctrl+Alt+F1 again, which will bring you back to your console in which you can see the output of what's going on during startup. This should show you where the startup is getting stuck to, and hopefully point you in the direction on what to do next.


--------------------
Corey Quilliam
(former) Linuxhelp.ca Administrator
cquilliam-AT-gmail-dot-com

Want to help out Linuxhelp.net? Check out our Linuxhelp Wiki and see if there are some articles you would like to submit!!

--
Ubuntu 8.04 64-bit - Work Laptop (HP-Compaq NC6400 Core2)
Kubuntu 8.04 64-bit - Desktop (HP m8120n QuadCore)
Ubuntu 6.04 - Server (I'm not upgrading this baby until support runs out in 2012) (Some old POS dell)
Go to the top of the page
 
+Quote Post
ktstone
post May 31 2005, 11:03 AM
Post #3


Whats this Lie-nix Thing?
*

Group: Members
Posts: 6
Joined: 21-May 05
Member No.: 5,019



This helped with starting applications once inside kde, however the kde startup time was not affected. Also, I tried ctrl+alt+f1 after logging in with kdm but all I see is a login prompt at the console. Does this help narrow down the possible causes?
Go to the top of the page
 
+Quote Post
DS2K3
post May 31 2005, 11:57 AM
Post #4


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,284
Joined: 14-November 04
From: Southampton, Hampshire
Member No.: 4,165



crtl-alt-backspace to kill X (if it restarts, then ctrl-alt-F1, login as root and "killall X"). Then run startx once you are logged in on the console to see startup messages.

D


--------------------
Fixed your problem? Let us know!
richard@linuxhelp.net

www.Gathr.co.uk Online Event Management
Go to the top of the page
 
+Quote Post
Corey
post May 31 2005, 12:04 PM
Post #5


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 1,254
Joined: 21-September 02
From: St John's, Newfoundland, Canada
Member No.: 3



QUOTE (ktstone @ May 31 2005, 01:33 PM)
This helped with starting applications once inside kde, however the kde startup time was not affected. Also, I tried ctrl+alt+f1 after logging in with kdm but all I see is a login prompt at the console. Does this help narrow down the possible causes?

At the KDM login prompt, press Ctrl+Alt+F1

Login as root

Run:

QUOTE
/etc/init.d/kdm stop


Logout as root
Login as user

run 'startx'

press Ctrl+Alt+F1 back to console to see the console output of your KDE session.


--------------------
Corey Quilliam
(former) Linuxhelp.ca Administrator
cquilliam-AT-gmail-dot-com

Want to help out Linuxhelp.net? Check out our Linuxhelp Wiki and see if there are some articles you would like to submit!!

--
Ubuntu 8.04 64-bit - Work Laptop (HP-Compaq NC6400 Core2)
Kubuntu 8.04 64-bit - Desktop (HP m8120n QuadCore)
Ubuntu 6.04 - Server (I'm not upgrading this baby until support runs out in 2012) (Some old POS dell)
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 22nd October 2017 - 05:59 PM