Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> Dvd Burning Locks Up My Computer, growisofs on AMD64 isn't working
wackman
post May 20 2005, 04:55 AM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 1
Joined: 20-May 05
Member No.: 5,015



Hey everyone,

I've been posting this to a few forums and no one has been able to help (no one's even posted a reply). I've tried at forums.gentoo.org and linuxquestions.org. Nada. If anyone can help with this, please do. Since it's now 4am and I need to get to bed, I'm going to just post my post from gentoo. It explains it pretty well. Sorry if it's a bit long winded, but I wanted to give as much info as I could:

I've been using Gentoo off and on since the pre1.0 days. For the last year or so, I haven't tried burning DVDs because I wanted to get a handle on avidemux and things. I didn't want to burn a DVD until I had content I wanted to burn.

Anyway, whenever I try burning a DVD, growisofs locks my computer up. I have to power off manually, then restart my computer. Normally, I usually use guis like k3b. I'm not a cli person. Sorry, I'm just not. In K3b, the progress indicator would get to 50% once it built the dvd iso, then the light would come on, then within 10 seconds the computer locks up. The light on my drive still flashes as if it's burning something, but nothing happens. Even the buffer indicator at the bottom says "no info" as if it's not able to query or fill the buffer on the drive.

A while back, I tried arch and the same thing happened. I reinstalled 2005.0 thinking there was something funky in Arch's kernel. Still the same problem.

This time, I decided to try growisofs from konsole session and copy and paste what was happening:

OK, the copy and paste didn't work. I'll try to do this from memory. Forgive me if it's not 100% acurate to what growisofs does:

CODE
bash-2.05b# growisofs -dvd-compat -Z /dev/scd0=k3b.iso

mkisofs | dd if=k3b.iso of=/dev/scd0
mkisofs burning at 8x (8196 kb/sec)

0/1571323904 00% ??:??
0/1571323904 00% ??:??
0/1571323904 00% ??:??
0/1571323904 00% ??:??
0/1571323904 00% ??:??
0/1571323904 00% ??:??
0/1571323904 00% ??:??
0/1571323904 00% ??:??



then it locks up

Now, a little bit about my computer and setup. Ignore the computer stats in my sig. I haven't updated this since way before I upgraded. My computer is currently like this:

Athlon64 3000+
512MB RAM
Abit AV8

Gentoo 2005.0 (AMD64)
2.6.11-gentoo-r7

A couple hours ago, I was scouring the posts here and was reminded this could be due to a bad cable. I swapped cables and it's still happening (in the process, I accidentally unplugged my floppy - will fix that tomorrow). Incidentally, I tried running hdparm on my burner and it gave me an error:

CODE
bash-2.05b# hdparm /dev/scd0

/dev/scd0:
readonly     =  0 (off)
readahead    = 256 (on)
HDIO_GETGEO failed: Invalid argument


My portage was last synced a couple days ago. I have done this as root only. I only use root on my computer (I know, not a wise thing, I'm the only one who ever uses this computer and I know the risks). I have all the scsi emulation stuff compiled into the kernel (I also like monolithic kernel builds - few or no modules). I may try to find the homepage for dvdrtools tomorrow to checkout a cvs version.

My burner is an LG 4081B. Firmware ver 104. I found an update firmware by googling, but it's only as an exe and I left windows for good when it died a while back. I don't have a way to use the exe I downloaded. I know the burner is fine since a) I can burn CD audio just fine and b)when my windows install was working, dvd burns were just fine.

Is this a 2.6 thing? Am I forgetting any scsi options in my kernel? Any patches anyone has heard of?

Anyway, I would appreciate any help anyone can give.

Thanks,

Wackman
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 22nd October 2017 - 07:51 PM