Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> I'm New To All This...., A little help needed...
scooby_doo_do
post Mar 5 2003, 09:54 AM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 7
Joined: 5-March 03
Member No.: 518



Hi, i'm all new to Linux, and i am installing a web server at work... When i try to start apachectl in the /etc/sbin area i get the following message :

SSLCertificateFile: file '/etc/httpd/conf/ssl.crt/server.crt' does not exist or is empty

I'm not too sure how to correct it ? Any help greatly appreciated.

Craig.
Go to the top of the page
 
+Quote Post
chrism01
post Mar 5 2003, 04:16 PM
Post #2


Whats this Lie-nix Thing?
*

Group: Members
Posts: 22
Joined: 12-February 03
Member No.: 435



Its implying you want to have Apache run https (aka SSL) which is on port 443. For this, you need an SSL certificate. You'll need to read up on this if you need SSL. To be honest, if you're not handling eg CC nums then you can probably manage on port 80 (normal http). The httpd.conf file has a lot of info/comments in it about how to enable/disable SSL.
Depends on your distro, but in RH the file location is /etc/httpd/conf/

HTH


--------------------
Cheers
Chris
Go to the top of the page
 
+Quote Post
chrisw
post Mar 5 2003, 04:56 PM
Post #3


RMS is my Hero
******

Group: Admin
Posts: 634
Joined: 27-September 02
From: Louisiana
Member No.: 5



if you really need SSL do the following:

try going into your /etc/httpd/conf/ssl.csr directory
and type:

make certificate

if it starts asking you some questions....follow
the directions on how to create a certificate...
if you are able to get through it you should
have a server.crt file....you
will then have to restart apache if you can....


if you type make certificate and you get an error...
paste it here and i will take a look at it....

if you dont need SSL

open up your httpd.conf file
which should be in /etc/httpd/conf/ directory

and find the line that says something like

SSLEngine On

change it to say

SSLEnging Off

and that should turn off SSL feature....

if not post errors here


--------------------

Chris W.
Go to the top of the page
 
+Quote Post
scooby_doo_do
post Mar 6 2003, 04:15 AM
Post #4


Whats this Lie-nix Thing?
*

Group: Members
Posts: 7
Joined: 5-March 03
Member No.: 518



Ok, i tried going to that directory and type make certificate and got the following error

make: *** No rule to make target `certificate'. Stop

Craig.
Go to the top of the page
 
+Quote Post
chrisw
post Mar 6 2003, 05:32 PM
Post #5


RMS is my Hero
******

Group: Admin
Posts: 634
Joined: 27-September 02
From: Louisiana
Member No.: 5



first off...do you really need SSL?

if so...i could write something up and post it here...
but it would be couple days....

is that ok with you?


--------------------

Chris W.
Go to the top of the page
 
+Quote Post
dc2000
post Mar 12 2003, 02:13 PM
Post #6


Whats this Lie-nix Thing?
*

Group: Members
Posts: 7
Joined: 7-March 03
Member No.: 528



You guys seem good at this..

How do I get SSH running? aaaah help please!
Go to the top of the page
 
+Quote Post
chrisw
post Mar 12 2003, 08:12 PM
Post #7


RMS is my Hero
******

Group: Admin
Posts: 634
Joined: 27-September 02
From: Louisiana
Member No.: 5



working on writing a apache/mysql/php/mod_ssl guide for everyone
having trouble

hopefully will finish it soon


--------------------

Chris W.
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 23rd October 2017 - 01:19 AM