Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> Debian Linux Apache Not Starting
ballbrainer
post May 4 2005, 01:30 AM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 2
Joined: 4-May 05
Member No.: 4,956



Everything seemed to be working well before i tried to fix sendmail to work with uebimiau. I restarted my box at some later point, and now apache doesnt work.


Failed to start apache :

Starting web server: apache[Mon Apr 4 03:36:36 2005] [warn] v127.0.0.1:80 has no VirtualHosts
failed

is what i get when i run it. The problem is that i never modified the httpd.conf file, so i dont know why it would act up all of a sudden.

if i remove the nameVirtualHosts entry from the conf file, i get a new error:

Failed to start apache :

Starting web server: apachefailed


As far as i know, i only changed settings in sendmail using webmin. Has anyone encountered a simliar problem?

Thanks for your time
Go to the top of the page
 
+Quote Post
ballbrainer
post May 4 2005, 01:32 AM
Post #2


Whats this Lie-nix Thing?
*

Group: Members
Posts: 2
Joined: 4-May 05
Member No.: 4,956



i also forgot to mention, i cant still access webmin, and 42go.... so apache seems to work only ports other than 80...
Go to the top of the page
 
+Quote Post
DS2K3
post May 4 2005, 05:59 AM
Post #3


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,284
Joined: 14-November 04
From: Southampton, Hampshire
Member No.: 4,165



Webmin has it's own built-in server, it has nothing to do with Apache.

Try unsinstalling apache making sure all the config files are gone, and reinstlalling it. That should give youu a "clean" config file.

D


--------------------
Fixed your problem? Let us know!
richard@linuxhelp.net

www.Gathr.co.uk Online Event Management
Go to the top of the page
 
+Quote Post
michaelk
post May 4 2005, 05:59 AM
Post #4


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,797
Joined: 23-January 03
Member No.: 360



I didn't find a clear answer by searching the web. How did you try to fix sendmail?

BTW webmin runs independent of apache.
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 22nd October 2017 - 09:39 PM