Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> 250gb Hd Not Working With 2.6 Kernel
AceOfShades
post Apr 15 2005, 05:37 PM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 2
Joined: 15-April 05
Member No.: 4,880



So I went and bought a Western Digital SATA 250 GB drive (obviously I should've spent more time on the net first) and put it in my box. Long story short the drive works fine under a 2.4 kernel, but doesn't even mount in 2.6.

Short story long:

The 250 drive is secondary master, formatted with WD's included boot CD tools (EZ-Drive), while I have a 20 GB drive as primary master where I install the OS (currently Debian Sarge with a 2.4 kernel). The 250 is essentially file storage, so nothing ever needed to be installed onto it. Now this setup was working fine for some time until one day the drive just stopped mounting. I don't recall changing anything, which is why it's causing so much trouble as I can't figure out what precisely went wrong. I know the drive is still fine for when I mount it while booting from a live CD all my data is still there. I've decided however to just leave it be and try to figure out the big picture: why it won't work in 2.6.

For testing purposes I'm using SimplyMEPIS since the liveCD contains both 2.4.26 and 2.6.7 kernels. For those not familiar, it's a Debian based system.

Booting into 2.4 everything runs fine. I can mount the drive, read from and write to it with no problems. Boot into 2.6 however...
root@0[root]# mount /dev/hdc1
mount: you must specify the filesystem type
root@0[root]# mount -t vfat /dev/hdc1 /mnt/hdc1 <-- vfat is what 2.4 uses, but I tried other types with the same result
mount: wrong fs type, bad option, bad superblock on /dev/hdc1, or too many mounted file systems

Days of Googleing have provided me with no answers.

root@0[root]# fdisk -l /dev/hdc
(2.4 kernel)
Disk /dev/hdc: 250.0 GB, 250059350016 bytes
255 heads, 63 sectors/track, 30401 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/hdc1 * 1 30401 244196001 c W95 FAT32 (LBA)

(2.6 kernel)
Disk /dev/hdc: 250.0 GB, 250059350016 bytes
255 heads, 63 sectors/track, 30401 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/hdc1 * 1 1023 8217243 55 EZ-Drive


While this is the output of Mepis, I've tried various other live CDs (including Ubuntu, dyne:bolic, Devil Linux, and an old version of Knoppix) and got the same results based on the kernel used.

With the data I've already managed to store on the drive, I'd rather not have to reformat it if that can be avoided, as I really have nowhere to back all of this up (that was the purpose of the drive in the first place: backup). I'm hoping this is specifically a Linux problem. Any suggestions? Any more information I need to provide?
Go to the top of the page
 
+Quote Post
michaelk
post Apr 16 2005, 08:48 AM
Post #2


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,797
Joined: 23-January 03
Member No.: 360



EZ-drive is a software solution so that a PC can use a larger drive then its BIOS can handle. The drive mapping was automaticlly detected in the 2.4 kernels but this feature was removed in the 2.5 kernels.

Adding this option to your 2.6 kernel bootloader should fix the problem.
hdc=remap

http://www.faqs.org/docs/Linux-HOWTO/Large...Disk-HOWTO.html
Go to the top of the page
 
+Quote Post
AceOfShades
post Apr 17 2005, 04:37 PM
Post #3


Whats this Lie-nix Thing?
*

Group: Members
Posts: 2
Joined: 15-April 05
Member No.: 4,880



Well snap, it was that easy. My friend, I owe you a beer.
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 18th October 2017 - 07:59 AM