Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> Need Help With Grub, Total Newbie on Linux
Rolldogg77
post Apr 7 2005, 06:17 AM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 3
Joined: 7-April 05
Member No.: 4,833



I was installing Red Hat to my windows machine on a seperate hard drive from my windows partitions and I messed up the install of Red Hat and now when my system boots it goes directly to the Grub screen and I look through all the commands and cant figure out which one to get to my windows partion or even to maybe skip the grub screen I also deleted the partions where linux resided on my machine but this screen still comes up. Could someone please help me I feel like such an idiot.
Go to the top of the page
 
+Quote Post
Jim
post Apr 7 2005, 05:02 PM
Post #2


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,280
Joined: 19-November 03
From: University of Minnesota- TC
Member No.: 1,828



GRUB resides on the MBR of your master hard drive, deleting the partitions wont help, actually it was the worst thing for you to do.

Booting into windows from grub is easy if you can add an entry to your grub.conf file, but you no longer have one of those.

So, what you need to do is thus. Either you can reinstall linux if you would like to have linux on your system and then we can add an entry to your grub.conf file for windows so you can boot into windows from GRUB. Or, you can manually create a temporary entry to boot yourself into windows and then restor the MBR.

If you want to boot into windows you need to either edit one of the entries, or I think there is a new entry command, what ever, there should be a information at the bottom to tell you want you want. You just need to form a boot command that look like this

CODE
rootnoverify (hd0,0)
makeactive
chainloader +1


Thats three distinct lines, and asuming your window partition is on the primary partition of your master drive.

If you want to re-install linux, you can add an entry to /boot/grub/grub.conf that looks like this.

CODE
title= "Windows"
rootnoverify (hd0,0)
makeactive
chainloader +1


That should get you set up. Let me know if you have any more questions.


--------------------
--Jim Lester
jim@linuxhelp.net

Distro: Gentoo
System: AMD Athlon 3000+ XP 2.166 GHz
NVIDIA nForce2 IGP Chipset
1GB 333 MHz DDR SDRAM
NVIDIA nForce2 Dual Head 64 MB Graphics

Server Distro: CentOS
Go to the top of the page
 
+Quote Post
Rolldogg77
post Apr 8 2005, 08:12 AM
Post #3


Whats this Lie-nix Thing?
*

Group: Members
Posts: 3
Joined: 7-April 05
Member No.: 4,833



Thanks Jim But I didnt need to do all that I just booted off my xp cd and went into recovery console and used the "fixmbr" command that worked great got me back to windows. But heres another problem you may be able to help me with when I go to start WinX in linux when I type "startx" I get an error message "fatal IO error something 104" and I know why this is happening when I am installing Linux, the installation goes through until I get to the part about the the monitor settings after you choose your video driver the install comes up with a bug I saved the bug to floppy but I dont know what to do with it, also I just downloded fedora 3, should I just quit trying to install Red Hat 9 and put my efforts into Fedora 3
Go to the top of the page
 
+Quote Post
Jim
post Apr 8 2005, 02:07 PM
Post #4


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,280
Joined: 19-November 03
From: University of Minnesota- TC
Member No.: 1,828



Thats what I would recomend. Red Hat is dead, there aren't releasing any more updates for it, so I woud go with some version fo Fedora.

Also what kind of video card do you have? Its got to be some settings in the X config files. Try installing Fedora and we will get that working.


--------------------
--Jim Lester
jim@linuxhelp.net

Distro: Gentoo
System: AMD Athlon 3000+ XP 2.166 GHz
NVIDIA nForce2 IGP Chipset
1GB 333 MHz DDR SDRAM
NVIDIA nForce2 Dual Head 64 MB Graphics

Server Distro: CentOS
Go to the top of the page
 
+Quote Post
Rolldogg77
post Apr 8 2005, 07:49 PM
Post #5


Whats this Lie-nix Thing?
*

Group: Members
Posts: 3
Joined: 7-April 05
Member No.: 4,833



Jim Once again thanks for your help, I installed Fedora Core 3 and it installed fine and the monitor is working now. The only problem I am Having now is that there is no sound I have a creative soundblaster audigy live sound card it autodetects the card but there is no sound I am downloading all available updates now for the os, hopefully that will fix it, if not got any suggestions.
Go to the top of the page
 
+Quote Post
Jim
post Apr 9 2005, 02:38 PM
Post #6


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,280
Joined: 19-November 03
From: University of Minnesota- TC
Member No.: 1,828



There are specific drivers available for the audigy. If you you can't get it running after updating, hit google and try to find them. They should work.


--------------------
--Jim Lester
jim@linuxhelp.net

Distro: Gentoo
System: AMD Athlon 3000+ XP 2.166 GHz
NVIDIA nForce2 IGP Chipset
1GB 333 MHz DDR SDRAM
NVIDIA nForce2 Dual Head 64 MB Graphics

Server Distro: CentOS
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 20th October 2017 - 08:30 PM