Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> Firewall Problem (rh 9), open all ports to anything & anyone
cagey cretin
post Apr 3 2005, 09:23 AM
Post #1


./configure
***

Group: Members
Posts: 96
Joined: 9-September 03
Member No.: 1,413



Std distro of RH 9, lokkit and iptables. I can telnet to localhost 25 but not *ip-address-of-eth0*. Connection always refused. I've tried setting lokkit to no firewall, and connection still refused. I've uninstalled iptables and lokkit. Connection still refused (yeah, that makes sense).

Postfix is running. I can send mail telnetting to localhost 25.

TIA
Go to the top of the page
 
+Quote Post
DS2K3
post Apr 3 2005, 12:52 PM
Post #2


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,284
Joined: 14-November 04
From: Southampton, Hampshire
Member No.: 4,165



In that case, Postfix probably isnt listening tongue.gif

Have a look in the postfix config (normally /etc/postfix/amin.cf) and tell it to listen on the IP of eth0 (it is pretty well commecnted you shouldnt have any probs)

D


--------------------
Fixed your problem? Let us know!
richard@linuxhelp.net

www.Gathr.co.uk Online Event Management
Go to the top of the page
 
+Quote Post
cagey cretin
post Apr 3 2005, 02:14 PM
Post #3


./configure
***

Group: Members
Posts: 96
Joined: 9-September 03
Member No.: 1,413



Thanks for the reply Richard. I have a book published by SAMS (Blum's "Postfix") and on page 168, 'it is written' that by default postfix listens on all interfaces. Nice new fresh reinstall, and I looked at the main.cf. Infact, inet_interfaces = local host was the uncommented item (contrary to the book). I changed it to "all", restarted the daemon, the network service, and the system itself for good measure. No good. Matter of fact, I get the exact same message...

Thanks again for the reply.

Joe
Go to the top of the page
 
+Quote Post
cagey cretin
post Apr 3 2005, 02:28 PM
Post #4


./configure
***

Group: Members
Posts: 96
Joined: 9-September 03
Member No.: 1,413



Well now. Seems the joke is on me.

Evidently, I must remove sendmail before using postfix. I have spent the better part of 2 days trying to get to the bottom of this. Finally, RedHat's HowTo states that sendmail must be removed. I've been through most of this book, and I find no mention of Sendmail removal.

Now that sendmail is gone, I can telnet using the ip of the ethernet card.

Maybe this will help someone else...

Joe
Go to the top of the page
 
+Quote Post
DS2K3
post Apr 3 2005, 03:24 PM
Post #5


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,284
Joined: 14-November 04
From: Southampton, Hampshire
Member No.: 4,165



A lot of distributors change the default settings for security reasons. Just ebcasue the official postfix releases have a certain option set to something by default, doesnt mean the versions that chip with the various distributions do too.

Yeh, generally having two MTAs isnt a good idea - That's why I like Gentoo/Portage - It takes care of stuff like that for you.

Glad its working now

D


--------------------
Fixed your problem? Let us know!
richard@linuxhelp.net

www.Gathr.co.uk Online Event Management
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 15th December 2017 - 01:04 PM