Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> .htaccess, How do I set up .htaccess?
LIJay
post Mar 1 2005, 09:27 PM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 2
Joined: 1-March 05
Member No.: 4,720



This is my first time owning a dedicated server, its a redhat linux 9.0 with webmin control panel and I put a .htaccess file in one of my dirs and it just won't work. I know all of the code in it is correct because it works for my other site that isn't on a dedicated server. Is there some setup proccess I have to do inorder to make the .htaccess file work?
Go to the top of the page
 
+Quote Post
Corey
post Mar 2 2005, 07:16 PM
Post #2


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 1,254
Joined: 21-September 02
From: St John's, Newfoundland, Canada
Member No.: 3



http://wiki.linuxhelp.net/index.php/Htaccess_Setup


--------------------
Corey Quilliam
(former) Linuxhelp.ca Administrator
cquilliam-AT-gmail-dot-com

Want to help out Linuxhelp.net? Check out our Linuxhelp Wiki and see if there are some articles you would like to submit!!

--
Ubuntu 8.04 64-bit - Work Laptop (HP-Compaq NC6400 Core2)
Kubuntu 8.04 64-bit - Desktop (HP m8120n QuadCore)
Ubuntu 6.04 - Server (I'm not upgrading this baby until support runs out in 2012) (Some old POS dell)
Go to the top of the page
 
+Quote Post
LIJay
post Mar 2 2005, 08:38 PM
Post #3


Whats this Lie-nix Thing?
*

Group: Members
Posts: 2
Joined: 1-March 05
Member No.: 4,720



I don't want to password protect a Dictonary, I just want .htaccess to work and I know my code in it is fine since it works on my other server. My dedicated server is acting as though there is no .htaccess in my dir.
Go to the top of the page
 
+Quote Post
Termina
post Mar 3 2005, 11:47 AM
Post #4


RMS is my Hero
******

Group: Support Specialist
Posts: 862
Joined: 18-February 04
From: Wisconsin
Member No.: 2,404



You'll have to edit your httpd.conf file then (find / -name httpd.conf)

Can you post your .htaccess file here, so we might know what you need to change?
Most likely you'll just need to add/uncomment:


AllowOverride None (under Options Indexes FollowSymLinks)

And under (Directory Index) line, uncomment/add

AccessFileName .htaccess

Make sure to have the following below AccessFileName line, so people can't view your .htaccess/.htpasswd files.

CODE
<Files ~ "^.ht">
   Order allow,deny
   Deny from all
</Files>


--------------------
*Points finger at the author above him* They're a witch! Burn them!
---
Vist my website!
Join me in IRC! Server: st0rage.org Channel: #UnhandledExceptions
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 15th December 2017 - 11:03 AM