Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> Help, LINUX GRUB
PETEYPABLO
post Jan 19 2005, 09:16 PM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 1
Joined: 19-January 05
Member No.: 4,545



I HAVE 2 HARD DRIVES. ONE IS A ATA AND THE OTHER IS A IDE. I HAD WINDOWS XP IN ONE OF THESE. I BELIEVE IT WAS THE IDE. WHEN I INSTALLED FEDORA I THINK I INSTALLED IT TO THE ATA HARD DRIVE. I ALSO ENABLED GRUB WHICH SOME PEOPLE TELL ME I SHOULDN'T HAVE. WHEN I TURN ON MY COMPUTER IT GOES STRAIGHT TO FEDORA. I WANTED TO HAVE A DOUBLE BOOT OPTION. I DID THE (DF -H) COMMAND BUT I DONT UNDERSTAND IT. I ALSO DID THE (/SBIN/FDISK AND THE CAT /ETC/FSTAB) BUT I ALSO DONT UNDERSTAND HOW TO READ IT. I AM A NEW USER YESTERDAY WAS THE FIRST TIME I USED AND INSTALLED FEDORA. SOME FRIENDS TOLD ME TO MAKE A TITLE UNDER THE (VI /ETC/GRUB.CONF) BUT NOTHING COME OUT ONLY A BUNCH OF THESE (~) AND I GET PERMISSION DENIED. CAN SOMEONE PLEASE HELP ME. THANKS


[peter@localhost ~]$ df -h
Filesystem Size Used Avail Use% Mounted on
/dev/mapper/VolGroup00-LogVol00
72G 2.8G 65G 5% /
/dev/sda1 99M 19M 76M 20% /boot
none 505M 0 505M 0% /dev/shm
[peter@localhost ~]$ /sbin/fdisk

Usage: fdisk [-l] [-b SSZ] [-u] device
E.g.: fdisk /dev/hda (for the first IDE disk)
or: fdisk /dev/sdc (for the third SCSI disk)
or: fdisk /dev/eda (for the first PS/2 ESDI drive)
or: fdisk /dev/rd/c0d0 or: fdisk /dev/ida/c0d0 (for RAID devices)
...
[peter@localhost ~]$ cat /etc/fstab
# This file is edited by fstab-sync - see 'man fstab-sync' for details
/dev/VolGroup00/LogVol00 / ext3 defaults 1 1
LABEL=/boot /boot ext3 defaults 1 2
none /dev/pts devpts gid=5,mode=620 0 0
none /dev/shm tmpfs defaults 0 0
none /proc proc defaults 0 0
none /sys sysfs defaults 0 0
/dev/VolGroup00/LogVol01 swap swap defaults 0 0
/dev/hdc /media/cdrom auto pamconsole,fscontext=system_u:object_r:removable_t,exec,noauto,managed 0 0
/dev/hda /media/cdrecorder auto pamconsole,fscontext=system_u:object_r:removable_t,exec,noauto,managed 0 0
/dev/fd0 /media/floppy auto pamconsole,fscontext=system_u:object_r:removable_t,exec,noauto,managed 0 0
[peter@localhost ~]$
HERE IS MY GRUB.CONF FILE
#boot=/dev/hdb
default=1
timeout=5
splashimage=(hd1,0) /grub/splash.xpm.gz
hiddenmenu
title fedora core (2.6.10-1.741_fc3)
root (hd1,0)
kernel /vmlinuz-2.6.10-1.741_fc3 ro root=/dev/VolGroup00/LogVol100 rhgb quiet
initrd /initrd-2.6.10-1.741_fc3.img
title fedora core (2.6.10-1.741_fc3smp)
root (hd1,0)
kernel /vmlinuz-2.6.10-1.741_fc3smp ro root=/dev/VolGroup00/LogVol100 rhgb quiet
initrd /initrd-2.6.10-1.741_fc3smp.img
title other
rootnoverify (hd0,1)
chainloader +1
title windows xp
rootnpverify (hd0,0) [b]
chainloader +1
Go to the top of the page
 
+Quote Post
Jim
post Jan 19 2005, 11:31 PM
Post #2


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,280
Joined: 19-November 03
From: University of Minnesota- TC
Member No.: 1,828



You need to edit your /boot/grub/grub.conf file. Let me walk you through how and what changes you need to make.

First, you need root privilege, so type this command in su then your root password when it promts you.

Second, move to /boot/grub by running cd /boot/grub and list the files with ls You should see a file called grub.conf if you don't, look in /etc or /etc/grub

Now, you need to edit the file, vi works fine and if you know how to use it go ahead, but if you don't, I recomend emacs because its easier to use. Open the file by running emacs grub.conf

Your file should look something like this
CODE
default 0
timeout 10

title= Gentoo
root(hd1,0)
kernel /kernel-2.6.8-gentoo-r3 root=/dev/hdb3
initrd /initrd-2.6.8-gentoo-r3

title= Windows
root (hd0,0)
makeactive
chainloader +1


Your information for entries will be different and it should be, but the general format should be the same. Your timeout is probably set to 0 (thats why it goest straight to Fedora) so up it to what ever you want. You also need to form a entry for Windows if you don't have it. The only thing you would need to change from the one above is the root (hd0,0)[b] but you only need to change it if your windows drive [b]isn't on the first partition of the master drive, which I think it is.

You can set the default too if you want, setting it to 0 makes it boot the first entry at the end of the time out (the time out is in seconds) 1 makes it boot the second entry and so on. Save it and reboot, you should be ok. If you aren't come back and we can help you out. Post your conf file if you are having problems.


--------------------
--Jim Lester
jim@linuxhelp.net

Distro: Gentoo
System: AMD Athlon 3000+ XP 2.166 GHz
NVIDIA nForce2 IGP Chipset
1GB 333 MHz DDR SDRAM
NVIDIA nForce2 Dual Head 64 MB Graphics

Server Distro: CentOS
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 15th December 2017 - 03:32 AM