Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> Debian, Apache, And Php 4, Problems with PHP 4
ddemland
post Jan 8 2005, 06:50 PM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 1
Joined: 8-January 05
Member No.: 4,459



I have install the PHP 4 Debian package and made all the changes to the http.conf file for PHP. These changes included the new lines being added:

LoadModule php4_module /usr/lib/apache/1.3/libphp4.so

AddType application/x-httpd-php .php
AddType application/x-httpd-php .php4
AddType application/x-httpd-php .php3
AddType application/x-httpd-php-source .phps
AddType application/x-httpd-php .phtml

DirectoryIndex index.html index.php index.php3 index.php4 index.phtml index.htm index.shtml index.cgi

I have read about adding a line like:

AddModule mod_php4.c

But this only gets the message:

[warn] module mod_php4.c is already added, skipping

In any case the basic problem is simple. I can get any file with a .php3, or .php4, extension to run, but when I try a file with a .php extension all I get is a prompt to download the file.

What am I missing?

Thank You,

David
Go to the top of the page
 
+Quote Post
DS2K3
post Jan 9 2005, 06:51 AM
Post #2


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,284
Joined: 14-November 04
From: Southampton, Hampshire
Member No.: 4,165



Justa tip -

AddType application/x-httpd-php .php
AddType application/x-httpd-php .php4
AddType application/x-httpd-php .php3

Can all go on one line, like AddType application/x-httpd-php .php .php4 .php3 .phtml

As for your problem, it is something to do with your mimie-type settings. The file is being sent as something oother than text/tml or text/plain which the browser can understand, so the browser decides it doesnt know what it is, and asks you where you want it saved.

Could you post a link to your httpd.conf file (posting it here might be a bit long...) and also check to see that x-htttpd-php is setup correctly in your systems mime-type settings

D


--------------------
Fixed your problem? Let us know!
richard@linuxhelp.net

www.Gathr.co.uk Online Event Management
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 22nd October 2017 - 09:23 PM